Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Maintenance Tool Will Not Update 5.8



  • I am trying to update to the latest version 5 release but the maintenance tool says "one valid repository required" when I try update components. I do not want to got to 6.0. The default option is to remove all components and that is not what I want.



  • Why was this post deleted?


  • Lifetime Qt Champion

    Hi,

    It is not.

    You can update your installation by selecting the corresponding entry when starting the updater.


  • Moderators

    I assume the error was "At least one valid and enabled repository required for this action to succeed."

    Could it be that your installation was done with an so-called "offline installer"? In this case you cannot change your installation; this is only supported with the online installer. Uninstall, and start from scratch.


Log in to reply