Systray icons don't show up on target machine Windows XP SP3



  • Hi,

    I have read several posts in the past but none seems to fix my issue. My target machine is a Windows XP box with SP3. My development box is also Windows XP SP3. The systray application works fine on the development machine. 
    

    Any ideas?

    Best,
    Chris


  • Moderators

    For the record: Which Qt version are you using? I will most likely not be able to help, but am pretty sure the Qt version is important to anybody who can;-)



  • so, if the icon does not show up,:

    • do you see any other icons in your app?
    • do you see other icons with the same file format (jpeg, png, gif, ...)
    • did you also install the imageformat plugins beside the Qt libs?


  • Hi,

    I am using Qt 4.7 and have tried to follow the advice of several of the previous threads.

    1. Added imageformats to my apps folder; doesn't work
    2. Added iconengines to my app folder; doesn't work
    3. Added plugins to my app folder; doesn't work
    4. Tried making a qt.conf file; doesn't work.

    Maybe someone can try the opposite. Maybe someone can make a configuration that works and then post the solution here (with a zip file)? That is my preferred request. Thank you.

    Best,
    Chris



  • BTW, I am just trying to get the stock systray to work, nothing fancy.

    Best,
    Chris



  • I know for sure, that it definitely works. It's most likely that Qt does not find the imageformats plugin your the icon itself is not deployed (did you copy it to the destination or did you put it into a resource file?).


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.