Please nominate your Qt Champions for 2021! https://forum.qt.io/topic/132134/looking-for-the-2021-qt-champions

Qt Design Studio 2.0 - Linux Mint 19.3 glibc error



  • Hi,

    Does anyone have the same problem when opening the latest version of Qt Design Studio 2.0 ?

    I am getting this error as pasted below:

    /opt/Qt/Tools/QtDesignStudio/lib/qtcreator/plugins/libQmlDesigner.so: Cannot load library /opt/Qt/Tools/QtDesignStudio/lib/qtcreator/plugins/libQmlDesigner.so: (/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by /opt/Qt/Tools/QtDesignStudio/lib/qtcreator/plugins/../libSqlite.so.2))

    Linux Mint 19.3 latest stable glibc version is 2.27 and I don't want to upgrade my system right now on Linux Mint 20.

    Any workaround ideas how to avoid this error ? Any possible downgrade on the Qt Design Studio ?

    Thanks.



  • Bump, same question



  • @nsourl said in Qt Design Studio 2.0 - Linux Mint 19.3 glibc error:

    glibc version is 2.27

    GLIBC_2.28' not found

    You can't use it with the version you have installed


Log in to reply