[SOLVED] mobility 1.2 build error



  • I have successfully built QT libs 4.7.3 using CodeSourcery arm-2009q1-203 toolchain, and I am using qmake to build QT arm projects with no issues (running on an OMAP L138 target).

    I am now trying to build QT Mobility 1.2.0, using the same toolchain and qmake, but it fails with the the following error message:

    ./make clean
    OK

    ./configure -qmake-exec /opt/qt/bin/qmake
    OK

    ./make
    ...
    ...
    /home/user/CodeSourcery/arm-2009q1-203/bin/arm-none-linux-gnueabi-g++ -c -pipe -g -fvisibility=hidden -fvisibility-inlines-hidden -Wall -W -D_REENTRANT -fPIC -DQT_SHARED -DQTM_PLUGIN_PATH="/home/user/Development/Files/QT/qt-mobility-opensource-src-1.2.0/install/plugins" -DQT_MAKEDLL -DQT_BUILD_SYSINFO_LIB -DQT_NO_NETWORKMANAGER -DQT_NO_UDISKS -DQT_NO_CONNMAN -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I/home/user/Development/Files/QT_2/qt-everywhere-opensource-src-4.7.3/mkspecs/qws/linux-omapl138-g++ -I. -I/opt/qt/include/QtCore -I/opt/qt/include/QtNetwork -I/opt/qt/include/QtGui -I/opt/qt/include -I../global -I../../build/Debug/QtSystemInfo/moc -I/home/user/Development/Files/tslib/target/usr/include -o ../../build/Debug/QtSystemInfo/qsystemgeneralinfo.o qsystemgeneralinfo.cpp
    In file included from linux/qsysteminfo_linux_p.h:61,
    from qsysteminfocommon_p.h:57,
    from qsystemgeneralinfo.cpp:43:
    linux/qsysteminfo_linux_common_p.h:452: error: ISO C++ forbids declaration of 'QUPowerDeviceInterface' with no type
    linux/qsysteminfo_linux_common_p.h:452: error: expected ';' before '*' token
    make[2]: *** [../../build/Debug/QtSystemInfo/qsystemgeneralinfo.o] Error 1
    make[2]: Leaving directory /home/user/Development/Files/QT/qt-mobility-opensource-src-1.2.0/src/systeminfo' make[1]: *** [sub-systeminfo-make_default] Error 2 make[1]: Leaving directory/home/user/Development/Files/QT/qt-mobility-opensource-src-1.2.0/src'
    make: *** [sub-src-make_default-ordered] Error 2
    ...
    ...

    Any ideas?

    thanks



  • Looking at the source code, found out it was a dependency to dbus (when building the QT libraries, dbus was not detected, therefore automatically disabled). Building dbus library, and re configuring and building QT libraries, solved this particular issue.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.