Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64'



  • Hi,

    I've been trying to build the qsqlmysql.dll for Qt5.14.2 for msvc2017. This was quite problematic, and I've encountered the same issues that a lot of people have previously had, but now I've run into a unique issue that no one on here seems to have asked about before, and a google search doesn't seem to be revealing any answers; an nmake error "module machine type 'x86' conflicts with target machine type 'x64'". This error is occurring when I run nmake install inside sqldrivers\mysql:> when trying to build the plugin.

    So far I've done the following in terms of building the plugin:

    1. Launched x64 Native Tools Command Prompt for VS2017, cd'd into C:\Qt\Qt5.14.2\5.14.2\Src\qtbase\src\plugins\sqldrivers and checked that qmake works by running "qmake -version".

    2. Run "qmake -- MYSQL_INCDIR="C:/Program Files/MySQL/MySQL Connector C 6.1.3/include" MYSQL_LIBDIR="C:/Program Files/MySQL/MySQL Connector C 6.1.3/lib""
      Which gives an output of:

      Running configuration tests...
      Checking for DB2 (IBM)... no
      Checking for InterBase... no
      Checking for MySQL... yes
      Checking for OCI (Oracle)... no
      Checking for ODBC... yes
      Checking for PostgreSQL... no
      Checking for SQLite (version 2)... no
      Checking for TDS (Sybase)... no
      Done running configuration tests.
      
       [...]
      
    3. Cd'd into C:\Qt\Qt5.14.2\5.14.2\Src\qtbase\src\plugins\sqldrivers\mysql and run "nmake install" which ends with the following output:

      Qt5Sql.lib(Qt5Sql.dll) : fatal error LNK1112: module machine type 'x86' conflicts with target machine type 'x64'
      NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual 
      Studio\2017\Community\VC\Tools\MSVC\14.16.27023\bin\HostX64\x64\link.EXE"' : return code '0x458'
      Stop.
      NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual 
      Studio\2017\Community\VC\Tools\MSVC\14.16.27023\bin\HostX64\x64\nmake.exe"' : return code '0x2'
      Stop.
      
    4. I then tried running the command in "3." in x86 Native Tools Command Prompt for VS2017 and in x64_x86 Cross Tools Command Prompt for VS2017, and the same error returns each time. Googling the issue only seems to bring back results specific to certain programs, etc.

    Any help would be greatly appreciated.


  • Lifetime Qt Champion

    @obradley said in Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64':

    qmake

    Which qmake are you calling here? Use absolute path to qmake from Qt installation you want to build for. Make sure both, MySql libs and Qt, are both same architecture.



  • Hi, running "qmake -version" in the x64 vs 2017 command prompt from the C:\Qt\Qt5.14.2\5.14.2\Src\qtbase\src\plugins\sqldrivers\mysql directory returns:

        QMake version 3.1
        Using Qt version 5.14.2 in C:/Qt/Qt5.14.2/5.14.2/msvc2017/lib
    

    This is the build I'm trying to make the plugin for.


  • Lifetime Qt Champion

    @obradley It looks like you MySQL libs are x86, but you're building for x86_64. Make sure you have x86_64 MySQL client libs build.



  • According to MySQL installer the version of the MySql Connector/C that I have is for a x64 architecture. The version of Qt that I downloaded is for a x86 architecture. Is there some way I can build for x86?


  • Lifetime Qt Champion

    @obradley Do you really want/need to use x86 Qt build? If not simply install x86_64 Qt version.
    QtCompany does not provide recent Qt versions as x86 builds as far as I know, so if you would need a recent Qt version you would need to build it by yourself.



  • @jsulm said in Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64':

    x86_64 Qt

    I am using Qt version 5.14.2. As far as I can see from the page http://download.qt.io/archive/qt/5.14/5.14.2/ the only version available for Windows is for x86, at least for the installer. Should I change to a more recent version?



  • @jsulm said in Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64':

    If not simply install x86_64 Qt version.

    Update: I just ran qtdiag in the command prompt and it returned the following:

    qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set_ciphersuites
    qt.network.ssl: QSslSocket: cannot resolve SSL_set_psk_use_session_callback
    Qt 5.14.2 (i386-little_endian-ilp32 shared (dynamic) release build; by MSVC 2017) on "windows"
    OS: Windows 10 Version 1909 [winnt version 10.0.18363]
    
    Architecture: x86_64; features: SSE2 SSE3 SSSE3 SSE4.1 SSE4.2 AVX AVX2
    
    Environment:
      QtMsBuild="C:\Users\OBradley\AppData\Local\QtMsBuild"
    
    Features: QT_NO_EXCEPTIONS
    
    Library info:
      PrefixPath: C:\Qt\Qt5.14.2\5.14.2\msvc2017
      DocumentationPath: C:\Qt\Qt5.14.2\Docs\Qt-5.14.2
      HeadersPath: C:\Qt\Qt5.14.2\5.14.2\msvc2017\include
      LibrariesPath: C:\Qt\Qt5.14.2\5.14.2\msvc2017\lib
      LibraryExecutablesPath: C:\Qt\Qt5.14.2\5.14.2\msvc2017\bin
      BinariesPath: C:\Qt\Qt5.14.2\5.14.2\msvc2017\bin
      PluginsPath: C:\Qt\Qt5.14.2\5.14.2\msvc2017\plugins
      ImportsPath: C:\Qt\Qt5.14.2\5.14.2\msvc2017\imports
      Qml2ImportsPath: C:\Qt\Qt5.14.2\5.14.2\msvc2017\qml
      ArchDataPath: C:\Qt\Qt5.14.2\5.14.2\msvc2017
      DataPath: C:\Qt\Qt5.14.2\5.14.2\msvc2017
      TranslationsPath: C:\Qt\Qt5.14.2\5.14.2\msvc2017\translations
      ExamplesPath: C:\Qt\Qt5.14.2\Examples\Qt-5.14.2
      TestsPath: C:\Qt\Qt5.14.2\5.14.2\msvc2017\tests
      SettingsPath:
    

    which seems to suggest that I am already using the x86_64 build. Is this not compatible with the x64 build I have for the MySQL C connector?


  • Lifetime Qt Champion

    @obradley QtCreator does not matter at all here. What matters is Qt.

    Try to start from a clean source tree (without any build artefacts from your previous builds) with "x86 Native Tools Command Prompt for VS2017 and in x64_x86 Cross Tools Command Prompt".



  • In order to be sure that there's no lingering dependency issues and a clean build environment I've uninstalled and re-installed both MySQL and Qt. My current SQL server version is 5.6.19 for an x64 architecture, and the C connector is 6.1.3 for x64. I'm reinstalling Qt 5.14.2 for x86_64. I'm then going to rerun the qmake process in x64_x86 Cross Tools Command Prompt. Is that correct?


  • Lifetime Qt Champion

    @obradley said in Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64':

    Cross Tools Command Prompt

    Not sure what you mean by "Cross Command"? Do you mean the Visual Studio command prompt? If so, then yes, that's what you should do.



  • @obradley said in Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64':

    x64_x86 Cross Tools Command Prompt for VS2017

    Ok I've reinstalled both MySQL and Qt and have just repeated steps 1 and 2 in my original question but now inside x64_x86 Cross Tools Command Prompt for VS2017 only for the output to be:

    Running configuration tests...
    Checking for DB2 (IBM)... no
    Checking for InterBase... no
    Checking for MySQL... no
    Checking for OCI (Oracle)... no
    Checking for ODBC... yes
    Checking for PostgreSQL... no
    Checking for SQLite (version 2)... no
    Checking for TDS (Sybase)... no
    Done running configuration tests.
    
    [...]
    

    Should I try a different VS command prompt since it worked in x64 Native Tools Command Prompt for VS2017, or will that just cause the issue to repeat itself?


  • Lifetime Qt Champion

    @obradley What does the config.log file says now?



  • I've pasted the contents of the log file below:

    Command line: "MYSQL_INCDIR=C:/Program Files/MySQL/MySQL Connector C 6.1.3/include" "MYSQL_LIBDIR=C:/Program Files/MySQL/MySQL Connector C 6.1.3/lib"
    Global lib dirs: [C:\\opensslx86\\lib C:\\Utils\\my_sql\\mysql-5.7.25-win32\\lib C:\\Utils\\postgresqlx86\\pgsql\\lib] ["C:\\Program Files (x86)\\Microsoft Visual Studio\\2017\\Community\\VC\\Tools\\MSVC\\14.16.27023\\ATLMFC\\lib\\x86" "C:\\Program Files (x86)\\Microsoft Visual Studio\\2017\\Community\\VC\\Tools\\MSVC\\14.16.27023\\lib\\x86" "C:\\Program Files (x86)\\Windows Kits\\NETFXSDK\\4.6.1\\lib\\um\\x86" "C:\\Program Files (x86)\\Windows Kits\\10\\lib\\10.0.17763.0\\ucrt\\x86" "C:\\Program Files (x86)\\Windows Kits\\10\\lib\\10.0.17763.0\\um\\x86"]
    Global inc dirs: [C:\\opensslx86\\include C:\\Utils\\my_sql\\mysql-5.7.25-win32\\include C:\\Utils\\postgresqlx86\\pgsql\\include] ["C:\\Program Files (x86)\\Microsoft Visual Studio\\2017\\Community\\VC\\Tools\\MSVC\\14.16.27023\\ATLMFC\\include" "C:\\Program Files (x86)\\Microsoft Visual Studio\\2017\\Community\\VC\\Tools\\MSVC\\14.16.27023\\include" "C:\\Program Files (x86)\\Windows Kits\\NETFXSDK\\4.6.1\\include\\um" "C:\\Program Files (x86)\\Windows Kits\\10\\include\\10.0.17763.0\\ucrt" "C:\\Program Files (x86)\\Windows Kits\\10\\include\\10.0.17763.0\\shared" "C:\\Program Files (x86)\\Windows Kits\\10\\include\\10.0.17763.0\\um" "C:\\Program Files (x86)\\Windows Kits\\10\\include\\10.0.17763.0\\winrt" "C:\\Program Files (x86)\\Windows Kits\\10\\include\\10.0.17763.0\\cppwinrt"]
    looking for library db2
    Trying source 0 (type inline) of library db2 ...
    sqlcli.h not found in [] and global paths.
    sqlcli1.h not found in [] and global paths.
      => source produced no result.
    Trying source 1 (type inline) of library db2 ...
      => source failed condition '!config.win32'.
    test config.sqldrivers.libraries.db2 FAILED
    looking for library ibase
    Trying source 0 (type inline) of library ibase ...
    ibase.h not found in [] and global paths.
      => source produced no result.
    Trying source 1 (type inline) of library ibase ...
      => source failed condition '!config.win32'.
    test config.sqldrivers.libraries.ibase FAILED
    looking for library mysql
    Trying source 0 (type mysqlConfig) of library mysql ...
    mysql_config not found.
      => source produced no result.
    Trying source 1 (type mysqlConfig) of library mysql ...
    mysql_config not found.
      => source produced no result.
    Trying source 2 (type mysqlConfig) of library mysql ...
    mysql_config not found.
      => source produced no result.
    Trying source 3 (type mysqlConfig) of library mysql ...
    mysql_config not found.
      => source produced no result.
    Trying source 4 (type inline) of library mysql ...
      => source failed condition '!config.win32'.
    Trying source 5 (type inline) of library mysql ...
    + cd /d C:\Qt\Qt5.14.2\5.14.2\Src\qtbase\src\plugins\sqldrivers\config.tests\mysql && C:\Qt\Qt5.14.2\5.14.2\msvc2017\bin\qmake.exe "CONFIG -= qt debug_and_release app_bundle lib_bundle" "CONFIG += shared warn_off console single_arch" "QMAKE_LIBDIR += C:\\opensslx86\\lib C:\\Utils\\my_sql\\mysql-5.7.25-win32\\lib C:\\Utils\\postgresqlx86\\pgsql\\lib" "INCLUDEPATH += C:\\opensslx86\\include C:\\Utils\\my_sql\\mysql-5.7.25-win32\\include C:\\Utils\\postgresqlx86\\pgsql\\include" "QMAKE_USE += mysql" "QMAKE_LIBS_MYSQL = \"-LC:/Program Files/MySQL/MySQL Connector C 6.1.3/lib\" -llibmysql" "QMAKE_INCDIR_MYSQL = \"C:/Program Files/MySQL/MySQL Connector C 6.1.3/include\"" C:/Qt/Qt5.14.2/5.14.2/Src/qtbase/src/plugins/sqldrivers/config.tests/mysql
    > Info: creating stash file C:\Qt\Qt5.14.2\5.14.2\Src\qtbase\src\plugins\sqldrivers\config.tests\.qmake.stash
    + cd /d C:\Qt\Qt5.14.2\5.14.2\Src\qtbase\src\plugins\sqldrivers\config.tests\mysql && set MAKEFLAGS=& nmake
    > Microsoft (R) Program Maintenance Utility Version 14.16.27044.0
    > Copyright (C) Microsoft Corporation.  All rights reserved.
    > 	cl -c -nologo -Zc:wchar_t -FS -Zc:rvalueCast -Zc:inline -Zc:strictStrings -Zc:throwingNew -Zc:referenceBinding -Zc:__cplusplus -O2 -MD -W0 -EHsc -DUNICODE -D_UNICODE -DWIN32 -D_ENABLE_EXTENDED_ALIGNED_STORAGE -DNDEBUG -I. -IC:\opensslx86\include -IC:\Utils\my_sql\mysql-5.7.25-win32\include -IC:\Utils\postgresqlx86\pgsql\include -I"C:\Program Files\MySQL\MySQL Connector C 6.1.3\include" -IC:\Qt\Qt5.14.2\5.14.2\msvc2017\mkspecs\win32-msvc -Fo @C:\Users\OLIVER~1\AppData\Local\Temp\nm9D9C.tmp
    > main.cpp
    > 	link /NOLOGO /DYNAMICBASE /NXCOMPAT /OPT:REF /INCREMENTAL:NO /SUBSYSTEM:CONSOLE "/MANIFESTDEPENDENCY:type='win32' name='Microsoft.Windows.Common-Controls' version='6.0.0.0' publicKeyToken='6595b64144ccf1df' language='*' processorArchitecture='*'" /MANIFEST:embed /OUT:mysql.exe @C:\Users\OLIVER~1\AppData\Local\Temp\nmA08B.tmp
    > main.obj : error LNK2019: unresolved external symbol _mysql_get_client_version@0 referenced in function _main
    > C:\Program Files\MySQL\MySQL Connector C 6.1.3\lib\libmysql.lib : warning LNK4272: library machine type 'x64' conflicts with target machine type 'x86'
    > mysql.exe : fatal error LNK1120: 1 unresolved externals
    > NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023\bin\HostX64\x86\link.EXE"' : return code '0x460'
    > Stop.
     => source failed verification.
    Trying source 6 (type inline) of library mysql ...
      => source failed condition '!config.win32'.
    test config.sqldrivers.libraries.mysql FAILED
    looking for library oci
    Trying source 0 (type inline) of library oci ...
    oci.h not found in [] and global paths.
      => source produced no result.
    Trying source 1 (type inline) of library oci ...
      => source failed condition '!config.win32'.
    test config.sqldrivers.libraries.oci FAILED
    looking for library odbc
    Trying source 0 (type inline) of library odbc ...
    + cd /d C:\Qt\Qt5.14.2\5.14.2\Src\qtbase\src\plugins\sqldrivers\config.tests\odbc && C:\Qt\Qt5.14.2\5.14.2\msvc2017\bin\qmake.exe "CONFIG -= qt debug_and_release app_bundle lib_bundle" "CONFIG += shared warn_off console single_arch" "QMAKE_LIBDIR += C:\\opensslx86\\lib C:\\Utils\\my_sql\\mysql-5.7.25-win32\\lib C:\\Utils\\postgresqlx86\\pgsql\\lib" "INCLUDEPATH += C:\\opensslx86\\include C:\\Utils\\my_sql\\mysql-5.7.25-win32\\include C:\\Utils\\postgresqlx86\\pgsql\\include" "QMAKE_USE += odbc" "QMAKE_LIBS_ODBC = -lodbc32" C:/Qt/Qt5.14.2/5.14.2/Src/qtbase/src/plugins/sqldrivers/config.tests/odbc
    + cd /d C:\Qt\Qt5.14.2\5.14.2\Src\qtbase\src\plugins\sqldrivers\config.tests\odbc && set MAKEFLAGS=& nmake
    > Microsoft (R) Program Maintenance Utility Version 14.16.27044.0
    > Copyright (C) Microsoft Corporation.  All rights reserved.
    > 	cl -c -nologo -Zc:wchar_t -FS -Zc:rvalueCast -Zc:inline -Zc:strictStrings -Zc:throwingNew -Zc:referenceBinding -Zc:__cplusplus -O2 -MD -W0 -EHsc -DUNICODE -D_UNICODE -DWIN32 -D_ENABLE_EXTENDED_ALIGNED_STORAGE -DNDEBUG -I. -IC:\opensslx86\include -IC:\Utils\my_sql\mysql-5.7.25-win32\include -IC:\Utils\postgresqlx86\pgsql\include -IC:\Qt\Qt5.14.2\5.14.2\msvc2017\mkspecs\win32-msvc -Fo @C:\Users\OLIVER~1\AppData\Local\Temp\nmA4D0.tmp
    > main.cpp
    > 	link /NOLOGO /DYNAMICBASE /NXCOMPAT /OPT:REF /INCREMENTAL:NO /SUBSYSTEM:CONSOLE "/MANIFESTDEPENDENCY:type='win32' name='Microsoft.Windows.Common-Controls' version='6.0.0.0' publicKeyToken='6595b64144ccf1df' language='*' processorArchitecture='*'" /MANIFEST:embed /OUT:odbc.exe @C:\Users\OLIVER~1\AppData\Local\Temp\nmA84B.tmp
     => source accepted.
    test config.sqldrivers.libraries.odbc succeeded
    looking for library psql
    Trying source 0 (type pkgConfig) of library psql ...
    pkg-config use disabled globally.
      => source produced no result.
    Trying source 1 (type psqlConfig) of library psql ...
    pg_config not found.
      => source produced no result.
    Trying source 2 (type psqlEnv) of library psql ...
    libpq-fe.h not found in [] and global paths.
      => source produced no result.
    Trying source 3 (type psqlEnv) of library psql ...
      => source failed condition '!config.win32'.
    test config.sqldrivers.libraries.psql FAILED
    looking for library sqlite2
    Trying source 0 (type inline) of library sqlite2 ...
    sqlite.h not found in [] and global paths.
      => source produced no result.
    test config.sqldrivers.libraries.sqlite2 FAILED
    looking for library tds
    Trying source 0 (type sybaseEnv) of library tds ...
    + cd /d C:\Qt\Qt5.14.2\5.14.2\Src\qtbase\src\plugins\sqldrivers\config.tests\tds && C:\Qt\Qt5.14.2\5.14.2\msvc2017\bin\qmake.exe "CONFIG -= qt debug_and_release app_bundle lib_bundle" "CONFIG += shared warn_off console single_arch" "QMAKE_LIBDIR += C:\\opensslx86\\lib C:\\Utils\\my_sql\\mysql-5.7.25-win32\\lib C:\\Utils\\postgresqlx86\\pgsql\\lib" "INCLUDEPATH += C:\\opensslx86\\include C:\\Utils\\my_sql\\mysql-5.7.25-win32\\include C:\\Utils\\postgresqlx86\\pgsql\\include" "QMAKE_USE += tds" "QMAKE_LIBS_TDS = -lNTWDBLIB" C:/Qt/Qt5.14.2/5.14.2/Src/qtbase/src/plugins/sqldrivers/config.tests/tds
    + cd /d C:\Qt\Qt5.14.2\5.14.2\Src\qtbase\src\plugins\sqldrivers\config.tests\tds && set MAKEFLAGS=& nmake
    > Microsoft (R) Program Maintenance Utility Version 14.16.27044.0
    > Copyright (C) Microsoft Corporation.  All rights reserved.
    > 	cl -c -nologo -Zc:wchar_t -FS -Zc:rvalueCast -Zc:inline -Zc:strictStrings -Zc:throwingNew -Zc:referenceBinding -Zc:__cplusplus -O2 -MD -W0 -EHsc -DUNICODE -D_UNICODE -DWIN32 -D_ENABLE_EXTENDED_ALIGNED_STORAGE -DNDEBUG -I. -IC:\opensslx86\include -IC:\Utils\my_sql\mysql-5.7.25-win32\include -IC:\Utils\postgresqlx86\pgsql\include -IC:\Qt\Qt5.14.2\5.14.2\msvc2017\mkspecs\win32-msvc -Fo @C:\Users\OLIVER~1\AppData\Local\Temp\nmAB87.tmp
    > main.cpp
    > .\main.cpp(2): fatal error C1083: Cannot open include file: 'sybfront.h': No such file or directory
    > NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023\bin\HostX64\x86\cl.EXE"' : return code '0x2'
    > Stop.
     => source failed verification.
    Trying source 1 (type sybaseEnv) of library tds ...
      => source failed condition '!config.win32'.
    test config.sqldrivers.libraries.tds FAILED
    

  • Lifetime Qt Champion

    @obradley said in Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64':

    C:\Program Files\MySQL\MySQL Connector C 6.1.3\lib\libmysql.lib : warning LNK4272: library machine type 'x64' conflicts with target machine type 'x86'

    You're still mixing x86 and x86_64. I think C:\Program Files\MySQL\MySQL Connector C 6.1.3\lib\libmysql.lib is x86 and not x86_64.



  • So I should build with the 86 bit VS command prompt? Apologies for the confusion it's my first time encountering these types of issues


  • Lifetime Qt Champion

    @obradley You should build what you want to have. If you need x86_64 build then install x86_64 MySQL Connector version.


  • Lifetime Qt Champion

    Hi,

    No, you should have your dependencies built for the same architecture are Qt. If you have a 64bit Qt then you need the 64bit version of the connector. There's no way to mix and match libraries built for different architectures.



  • Sorry I'm still confused about. The connector I have is x64 according to MySQL installer. The installer which I have for Qt is an x86 installer. Running Qt diag returns that the architechture is x86_64. So does this mean I can use the 64 bit MySQL connector? So instead of running the x64_x86 Cross Tools Command Prompt for VS2017 should I run the x86_x64 Cross Tools Command Prompt for VS2017? This would be an environment initialised for x86_x64? Or do I instead need to find an x86 version of the C connector?

    Apologies again for the confusion.


  • Lifetime Qt Champion

    The architecture of the installer has nothing to do with the architecture of the Qt versions you installed. The same goes for Qt Creator, it can be x86 or x86_64, it does not matter when it comes to the architecture of the libraries you are using to build your application.

    There's no cross-compilation going on: if you have everything as x86_64, just use the 64bit compiler.



  • @SGaist said in Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64':

    just use the 64bit compiler.

    Ok I'm now getting an error : NMAKE : fatal error U1073: don't know how to make 'install'


  • Lifetime Qt Champion

    @obradley Did you call nmake before? Please provide more information.



  • I repeated steps 1 through 3 in my original question, so the nmake install error is happening after the configuration for mySql from qmake returns a "yes". I go into the sqldrivers\mysql folder and run "nmake install" like it says to do in the documentation.



  • Ok calling nmake in the sqldrivers directory after configuration is still giving the "Qt5Sql.lib(Qt5Sql.dll) : fatal error LNK1112: module machine type 'x86' conflicts with target machine type 'x64'" error even though I am using the 64 bit compiler? (According to Microsoft docs the x64 Native Tools Command Prompt for VS 2017 does use the 64 bit compiler https://docs.microsoft.com/en-us/cpp/build/how-to-enable-a-64-bit-visual-cpp-toolset-on-the-command-line?view=msvc-160)

    If the connector is 64 bit and Qt is x86_64 then I still don't understand why I can't build in the 64 bit compiler.


  • Lifetime Qt Champion

    How exactly are you opening/configuring the command line ?



  • Thanks jsulm and SGaist for your help with this. Before I explain about the command line, I just want to quickly summarise progress so far.

    I've tried reinstalling Qt and MySql to ensure that they both have the same architecture:

    • For Qt, based on Jsulm's comment above and the fact that Qt's installer doesn't ask which architechture to use, I am assuming I have installled Qt 5.14.2 x64.

    • For mySql, according to Qt's instructions, since I have x64 Qt installed, I need the x64 mySql C connector, and no other components of the MySql installation are relevant for building the qmysql plugin. Having now played around with the MySql installer, depending on which C connector I install, I get a different error at the nmake stage of building the plugin.

    This is what I see when I run the MySql installer. It doesn't allow me to simultaneously install the 32 and 64 bit C connectors:

    ad8d1f57-309c-49b8-8b91-970af5df26dd-image.png

    When I have the 32 bit C connector installed (as shown in the screenshot above), the following qmake command runs fine:

    qmake -- MYSQL_INCDIR="C:\Program Files (x86)\MySQL\MySQL Connector C 6.1.3\include" MYSQL_LIBDIR="C:\Program Files (x86)\MySQL\MySQL Connector C 6.1.3\lib"
    

    However, when I then run nmake sub-mysql, nmake complains:

    NMAKE : fatal error U1073: don't know how to make '"C:\Program Files\MySQL\MySQL Connector C 6.1.3\include\mysql.h"'
    

    This makes sense because I have x64 bit qt installed, but qmake and nmake are being given the path to the 32 bit version of the C connector.

    When I have the 64 bit C connector installed, I run the following qmake command:

    qmake -- MYSQL_INCDIR="C:\Program Files\MySQL\MySQL Connector C 6.1.3\include" MYSQL_LIBDIR="C:\Program Files\MySQL\MySQL Connector C 6.1.3\lib"
    

    Now when I run nmake sub-mysql, I get the error reported at the beginning of this thread:

    Qt5Sql.lib(Qt5Sql.dll) : fatal error LNK1112: module machine type 'x86' conflicts with target machine type 'x64'
    

    The point of the above explanation is that nmake gives me a different error depending on whether I have the 32 bit or 64 bit mySql C connector installed, which means that I can be fairly confident that I have the 64 bit version of both MySql C connector and Qt based on the error messages that I am seeing from nmake.

    Visual Studio 2017 includes four different command prompts in which I can execute qmake and nmake:

    • x86 Native Tools Command Prompt for VS 2017
    • x64 Native Tools Command Prompt for VS 2017
    • x64_x86 Cross Tools Command Prompt for VS 2017
    • x86_x64 Cross Tools Command Prompt for VS 2017

    When I run qmake and nmake using the above commands in each of these four prompts, the error messages are the same as above , with one exception: when I call qmake for the 32 bit mySql driver in the 64 bit command prompts, or vice versa, qmake does not recognise that mySql has been configured at all when it gives the list of database drivers available.

    So in summary, whichever version of the MySql C connector I have installed, and whichever version of the command prompt I use, I always get the same errors.

    Thanks to you both again for your help with this issue, it is much appreciated.


  • Lifetime Qt Champion

    @obradley said in Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64':

    Qt5Sql.lib(Qt5Sql.dll) : fatal error LNK1112: module machine type 'x86' conflicts with target machine type 'x64'

    AFAIR, this message means that Qt5Sql is 32bit which is rather strange since it's supposed to be 64 based on what you wrote. Are you sure the correct qmake is called ? Do you have any Qt variable in your environment variables ?



  • Hi,

    I just wrote a quick console application in vs2017 for an x86 build that returns the value of the QSysInfo::currrentCpuArchitechture() and QSysInfo::buildCpuArchitechture() strings. They return x86_64 and i386 respectively. Since the current cpu architechture returns x86_64, this should mean that Qt is x86_64 am I correct?

    In my system path variables I have C:\Qt\Qt5.14.2\5.14.2\msvc2017\bin, and in my user variables I have C:\Users\OBradley\AppData\Local\QtMsBuild as QtMsBuild. These are the only Qt related variables I can find.

    Calling qmake -version returns

    QMake version 3.1
    Using Qt version 5.14.2 in C:/Qt/Qt5.14.2/5.14.2/msvc2017/lib
    

    The msvc2017 folder, I believe, contains 32 bit libraries since there is also I folder called msvc2017_64 which surely contains the 64 bit versions. Should I be using qmake from here?

    For context, I do want a 32 bit qsqlmysql.dll since I want to use it with a 32 bit vs2017 executable.


  • Lifetime Qt Champion

    @obradley said in Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64':

    For context, I do want a 32 bit qsqlmysql.dll since I want to use it with a 32 bit vs2017 executable.

    Then use qmake from 32bit Qt



  • @jsulm said in Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64':

    Then use qmake from 32bit Qt

    I'm wondering if the version of qmake being called is 32 bit because it resides in the msvc2017 folder and not the msvc2017_64 folder. Do you know of a way to test the architecture of the qmake that is being called?



  • @jsulm said in Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64':

    Then use qmake from 32bit Qt

    Update:
    Assuming that the qmake executable in the msvc2017 folder is the 32 bit qmake, I replaced the version of qmake sitting the MSVC2017 folder with the executable from the msvc2017_64 bit folder, which is most likely a 64 bit version of qmake. The current mySql C connector I have installed is the 64 bit version, so I then reran the qmake process in the two VS command prompts that configure for the 64 bit sql connector (x64 Native Tools Command Prompt for VS 2017 and x86_x64 Cross Tools Command Prompt for VS 2017). The result was the same error as before:

    Qt5Sql.lib(Qt5Sql.dll) : fatal error LNK1112: module machine type 'x86' conflicts with target machine type 'x64'
    NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023\bin\HostX86\x64\link.EXE"' : return code '0x458'
    Stop.
    NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023\bin\HostX86\x86\nmake.exe"' : return code '0x2'
    Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    Stop.
    

    To be certain I then redid the process in the x86 Native Tools Command Prompt for VS 2017 and the x64_x86 Cross Tools Command Prompt for VS 2017 and got the same result as before for those command prompts when trying to use a 64 bit C connector, i.e. qmake being unable to configure the sql driver:

    Running configuration tests...
    Checking for DB2 (IBM)... no
    Checking for InterBase... no
    Checking for MySQL... no
    

  • Lifetime Qt Champion

    @obradley said in Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64':

    For context, I do want a 32 bit qsqlmysql.dll since I want to use it with a 32 bit vs2017 executable.

    Then why

    @obradley said in Building QMYSQL Plugin with nmake for msvc2017: module machine type 'x86' conflicts with target machine type 'x64':

    The current mySql C connector I have installed is the 64 bit version,

    ?

    You can't mix and match libraries from different architecture.

    The fact that your Windows is 64 does not matter as it can run both 32 and 64bit code.



  • Hi,

    I've just done another clean install of Qt. This time I only installed the 32 bit msvc2017 folder and the source folders so as to keep things simple. I also uninstalled the Qt for Visual Studio plug in, and ensured that I was building using the 32 bit my sql c connector and this time the same steps I performed in my original question worked (except having qmake point to the 32 bit MySql connector in program files (x86) and using x86 Native Tools Command Prompt for VS 2017). It is worth pointing out that at some point previously I had tried building the dll with this exact setup when I was exhausting all combinations, and that because my system path variable points to the qmake that sits in the 32 bit msvc2017 folder, I was always using 32 bit qmake, so at some point my 32 bit attempts should have worked yet they did not.

    This leaves me with two possible candidates (I think) that possibly could have been causing the error, although I cannot spare time to investigate which one it was:

    1. Having multiple bit builds of Qt installed caused a conflict somewhere when building the 32 bit dll, and this was then resolved when I uninstalled the other builds and just had the 32 bit version.
    2. The Qt for VS2017 plugin was causing a conflict somewhere, which was then resolved when I uninstalled the plug in.

    Thank you both for your patience and your help.


Log in to reply