Important: Please read the Qt Code of Conduct -

Issues with pyside2 setup and Anaconda3

  • Hi there,

    I was about to describe my issues with the pyside2 setup on Anaconda3 when I finally solved it, but I thought I'll share it anyway so others don't have to go through the same procedure:

    I am trying to use pyside2 in my anaconda environment, but experience issues when I tried to run a Qml application (that uses QtQuick.Controls). I tried this for both Windows10 and Ubuntu 16.04 (in my VM).
    For both I tried installing pyside2 into the base environment first (via pip install pyside2) and tried to fix the occurring errors (qt.qpa.platform not found and after that further dll incompatibilities) by setting environment variables, but wasn't able to.
    I did finally get the application to run by removing all installed qt components (qt and pyside2) and reinstalling them from conda-forge (see However, this setup broke my anaconda GUI setup (i.e. I could not launch anaconda-navigator anymore).
    I did read that there are some folder renaming issues related to PyQt5 ( so I reinstalled Anaconda and tried installing pyside2 into a newly created environment i.e. not into "base". This worked perfectly for Windows10. For Ubuntu, however, I kept receiving the initial errors again. I then found some Qtbug reports that stated that installing Pyside2 via pip was not supported (
    So I added another environment in which I installed pyside2 package from the conda-forge channel via conda (I used the navigator GUI to add the additional channel and then selected the pyside2 package but command line should work equally well). This time I did not remove any other qt packages before and that finally also works for Ubuntu now.

Log in to reply