How to do remote profiling/analyze on N950 from QtCreator



  • Hi,

    I want to port an existing Qt open source application that was designed for desktop to N9/N950. At a minimum this means stripping the QWidget GUI based code from the existing app and replacing it with QML; It's working ok, however I observe that quite often the main GUI thread will get blocked for some time and MeeGo pops-up a dialog saying the app is unresponsive and offer to kill-it. This happens when I run the existing app (unmodified src code) on N950. Running it on Desktop PC I do not see any issues. I suspect this is because some processing in the existing app engine is done in the main GUI thread, and I want to add a new thread for this processing that is blocking the GUI thread.

    Therefore it would be really useful to do remote profiling on N950 from QtCreator and see what function eat the processor in the main GUI thread.

    But how do I do this?

    If in Mac OS X I go in Qt Creator in Analyze->Valgrind Function Profiler (Remote) a dialog pops-up with the following fields:

    Remote

    Host: - I enter the IP for N950 (e.g.192.168.2.15)

    User: - I enter root

    Port: - I leave the default value 22

    Password: - I enter the default password for root on N950 "rootme"

    Provate key: - I leave it empty

    Target

    Executable: I enter the location on N950 to my app's exacutable I want to analyze, e.g. /opt/MyApp/bin/MyApp

    Arguments: I leave this empty

    Working directory: I enter "."

    After I press ok I get the following error message in the Qt Creator console output:
    @Profiling /opt/MyApp/bin/MyApp
    ** Error: "valgrind" could not be started: Server rejected password. **
    ** Analyzing finished **@

    Does anyone know how to do remote profiling?

    On Windows there is no option to do local profiling from Qt Creator (because it would help me to profile the GUI thread on the desktop also) and on Mac OS there is no Valgrind installed... If Qt Creator could just use xCode for this I'm sure things would just work :D

    Thanks & regards,
    Ionut


  • Moderators

    Have you tried to test your device? That should check whether log-in is possible.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.