Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Could not find the Qt platform plugin "eglfs" in "", error in BeagleBoardBlack



  • Hi everybody.
    I start fighting against Qt about a month ago.
    Finally, i got my installation working well on Ubuntu 18.04 on a Virtual Machine.
    But, there is a problem:
    When I deploy a console "Hello world", it works perfectly.
    When I deploy any of the Graphic examples within Qt, no one worked, with the following error:

    ubuntu@beaglebone:/usr/local/qt5bbb/examples/quickcontrols/extras/dashboard$ ./dashboard 
    QML debugging is enabled. Only use this in a safe environment.
    qt.qpa.plugin: Could not find the Qt platform plugin "eglfs" in ""
    This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
    
    Available platform plugins are: linuxfb, minimal, offscreen, vnc.
    
    Aborted
    

    I try to fix it by myself, but i don't really understand the proposed solutions on other topics.

    The board on which im deploying is a BeagleBoardBlack, running Ubuntu 18.04 too.

    Thanks in advice.


  • Lifetime Qt Champion

    @Jeremas said in Could not find the Qt platform plugin "eglfs" in "", error in BeagleBoardBlack:

    When I deploy

    How do you deploy?
    Did you check https://doc.qt.io/qt-5/linux-deployment.html ? "Creating the Application Package" chapter.



  • @jsulm , do you refer to App or Qt deploy?
    I use the default static linking deployment for the apps and simply click on "Deploy" after build the project.
    About Qt, i try to follow the guide for de BBB (BeagleBoneBlack ARM board) on the Qt Wiki, uploading the files via Ssh.

    With a partner help, I realize that the plugins needed on the BBB are missing:

    ubuntu@beaglebone:/usr/local/qt5bbb/plugins/platforms$ ls
    libqlinuxfb.so  libqminimal.so  libqoffscreen.so  libqvnc.so
    

    Checking my ./configure , i let the -no-opengl flag, because the wiki exclude it and when i try to use it, doesn't work.
    I try to run the following ./configure:

    sudo ./configure -no-gcc-sysroot -device linux-beagleboard-g++ -device-option CROSS_COMPILE=/opt/gcc-linaro-7.5.0-2019.12-x86_64_armv8l-linux-gnueabihf/bin/armv8l-linux-gnueabihf- -sysroot /mnt/bbb-rootfs -opensource -confirm-license -optimized-qmake -reduce-exports -release -make libs -prefix /usr/local/qt5bbb -hostprefix /usr/local/qt5bbb -qt-zlib -qt-libpng -no-openssl -opengl es2 -eglfs -v
    

    But i got this error message:

    ERROR: Feature 'opengles2' was enabled, but the pre-condition 'config.win32 || (!config.watchos && !features.opengl-desktop && libs.opengl_es2)' failed.
    
    ERROR: Feature 'eglfs' was enabled, but the pre-condition '!config.android && !config.darwin && !config.win32 && features.egl' failed.
    
    ERROR: The OpenGL functionality tests failed!
    You might need to modify the include and library search paths by editing QMAKE_INCDIR_OPENGL[_ES2],
    QMAKE_LIBDIR_OPENGL[_ES2] and QMAKE_LIBS_OPENGL[_ES2] in the mkspec for your platform.
    

    I still trying to fix it, thanks for the reply!


  • Lifetime Qt Champion

    This post is deleted!

Log in to reply