Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Boot2Qt EGLFS does not work



  • Hello,

    I am relatively new in the embedded systems. As far as I understand EGLFS is platform for running visual Qt applications on top of EGL and OpenGL ES 2.0. Hence, in order to work the GPU must support OpenGL ES 2.0.

    I recently bought 2 computers that purposes are to be used as embedded devices in different areas. One of them is with Intel Celeron J1900 and the other one is with Intel Celeron 1037U. There are no external GPUs but only the integrated in the CPUs.

    I successuly created bootable USB stick with Boot2Qt. I selected the platform Intel NUC. Everything works perfectly on the PC with J1900 CPU. The Qt Launcher starts with the default settings (EGLFS).

    When tried to start the USB stick on the other PC (1037U) the Qt Launcher didn't start. Then I tried to upload custom application but again - it does not start. There is an error that it could not flip the page of the screen. After a big research I tried to start the app with the platform arg linuxfb. It started but there are some issues with the screen sizes, etc.

    My main question is even that the 1037U integrated GPU supports OpenGL ES 2.0 it does not work with EGLFS. I thought it could be related to the drivers.

    The second one is after setting size=<width>x<height>, mmsize=<width>x<height> and offset=<width>x<height> it still does not fit the screen perfectly. Actually, with and without theese args the area on the screen is absolutely the same - no changes.

    Some side thoughts: is there any difference when using linuxfb and eglfs in terms of performance and supported features?

    Any references, thoughts and actual help are really appreciated!


Log in to reply