Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Can't build libqwt.dylib on MAC



  • Hello,

    I posted this question on qtCentre.org but no one seems to have an answer. I tried googling but couldn't find a valid solution for my problem. Very simply I downloaded qwt-6.1.5.

    I extracted the tar file.
    qmake qwt.pro
    make
    sudo make install

    All I get is the libqwt_designer_plugin.dylib. I need the libqwt.dylib so I can include it in my project file. The above commands worked fine on Windows and CentOS but for some reason not on MAC. I tried including the designer library but I keep getting "Undefined Symbols for architecture x86_64". I really should be using the qwt lib since I'm not building custom widgets.

    Any idea why I'm not getting the qwt library built? I'm running on Catalina 10.15.7. Also using clang 10 and xcode 10.3 if that makes a difference.

    Thanks in advance.


  • Lifetime Qt Champion

    Hi,

    Which version of Qt are you using ?
    How did you install it ?
    Do you have any warning / message coming on the console ?



  • Qt 5.15 but I don't think it has to do anything with Qt. I'm building the qwt libraries. There were no warnings or errors.

    See above how I built and installed the libraries, same as CentOS.
    Download the 6.1.5 qwt tar file.
    Extract the tar file
    qmake qwt.pro
    make
    sudo make install

    That is it. I get one library libqwt_designer_plugin.dylib but not libqwt.dylib which is what I need.



  • Any help please?


  • Lifetime Qt Champion

    Sorry, I haven't had any trouble building it here. macOS is 10.13.6 with Xcode 10 as well.
    Note that if you get the designer plugin, it means that the qwt.framework was created otherwise the plugin can be linked.


Log in to reply