Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt Installer Framework, upgrade maintenancetool.exe



  • Hi all,
    I have an old working existing installation using IFW on Windows.
    Now I need to use a new repository using https but my maintenancetool.exe doesn't allow HTTPS ("unknown protocol"). Maybe I built in the past IFW without SSL support.
    Now I can generate a new installer and a new repo content using a new IFW binary and it works with HTTPS.
    The problem is on existing installations. After upgrading, it keep using old maintenacetool.exe. The only option I have is to remove and install the application using the new installer but it's not so good for users.

    Is there a way I can publish an application update that also overwrite existing maintenancetool.exe with a new one?

    Thanks


Log in to reply