Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Project ERROR: Qt5GStreamerQuick-1.0 development package not found



  • Hi,

    I'm using Ubuntu 18.04 and i want to use qt with gstreamer. I follow these steps one by one to install qt creator:

    -> sudo apt-get install build-essential
    -> sudo apt-get install qtcreator
    -> sudo apt-get install qt5-default

    Then I install the necessary libraries for the gstreamer with the commands below. (some libraries required for the project)

    -> sudo apt-get update
    -> sudo apt-get install --reinstall libxcb-xinerama0
    -> sudo apt-get install libqt5gstreamerquick-1.0-0
    -> sudo apt-get install libcairo2-dev
    -> sudo apt-get install libgstreamer1.0-0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-libav gstreamer1.0-doc gstreamer1.0-tools gstreamer1.0-x gstreamer1.0-alsa gstreamer1.0-gl gstreamer1.0-gtk3 gstreamer1.0-qt5 gstreamer1.0-pulseaudio

    When I installed the above packages, there was no error. But QtCreator produces the same error everytime when i build.

    Project ERROR: Qt5GStreamerQuick-1.0 development package not found

    I tried many things I found on the internet about the subject. I could not solve. I can't find of anything else to try.

    Hope someone can help me, I would appreciate any kind of help..



  • Development packages have -dev added, so you should search for those. They contain header files etc.



  • Sorry i forgot to write, I had already installed the -dev package which is libqt5gstreamer-dev.

    Should I install another package?



  • Hard to say, I am not Ubuntu guy. But I found this: https://forum.qt.io/topic/63557/qt5gstreamer-1-0-development-package-not-found/8



  • @suatberkantgulen related to the issue pointed out by @artwaw, I'd check if you have pkg-config installed.



  • Hi @artwaw and @Pablo-J-Rogina ,

    When I add the following line to the ".pro" file.

    • PKG_CONFIG += Qt5GStreamer-1.0 Qt5GStreamerQuick-1.0

    Qt5GStreamer-1.0 package does not cause any problem. But the other package gives me an error.

    Qt5GStreamerQuick-1.0 development package not found.

    Which part should I check?

    BTW : I configure my PKG_CONFIG_PATH like that:

    export PKG_CONFIG_PATH=/usr/lib/x86_64-linux-gnu/pkgconfig/

    I can see all .pc files under path : /usr/lib/x86_64-linux-gnu/pkgconfig
    Qt5GStreamer-1.0.pc
    Qt5GStreamerQuick-1.0.pc
    ...


  • Lifetime Qt Champion

    Hi,

    One thing to note, QtGStreamer is in unmaintained state since some times already.

    Depending on what you want to do, you can use QMediaPlayer with a custom pipeline.



  • Hi!

    Although a little old, I had the same problem.

    I found this discussion that helped me to solve and also helped me to learn how to debug the problem: https://github.com/baedert/corebird/issues/189

    Installing libgstreamer-plugins-base1.0-dev made the Qt5GStreamer*-1.0 development package not found vanish. :)

    Hope it helps.



  • @henriquebg Good job, thank you! This will hopefully help the others!


Log in to reply