Which is the latest version of Qt which will suit for developing UI applications for an am1808 based platform on which linux os shall be ported



  • hi… everyone
    i m very new to qt…my project is to develop an infra red thermometer and i have to develop UI screens using Qt. I m very confused while choosing Qt sdk as i have to use the latest version of it. my confusion is that the latest version which is 4.7.4 can be used to develop embedded applications and if not which version i should use…the processor i m using will be arm 1808…
    please guys do help me!!!


  • Moderators

    Welcome to this forum.

    You probably may use any version of Qt provided it has the functionality you are needing. If you are thinking of pure gui applications, you may want to look for an older version. Newer versions tend to have more functionality and are larger. Even so, this may not be generalized.

    More important for you is probably that you have to compile your own version for the embedded platform. Therefore you need to download an archive and configure and compile it.



  • Hi Everyone,

    I am developing a UI application using Qt. when i am trying to build my code, it is building properly but when i am trying to run it then i am getting an error widow which is flashing as

    " The inferior stopped becuase it received a signal from operating system

    signal name- SIGSEGV
    signal meaning - segmentation fault


  • Moderators

    [quote author="gauravverma" date="1322833141"]Hi Everyone,

    I am developing a UI application using Qt. when i am trying to build my code, it is building properly but when i am trying to run it then i am getting an error widow which is flashing as

    " The inferior stopped becuase it received a signal from operating system

    signal name- SIGSEGV
    signal meaning - segmentation fault
    [/quote]

    You should start an independent thread for your issue.



  • segmentation fault is caused by illegal access to the memory. You must check with your codes.



  • [quote author="koahnig" date="1322832263"]Welcome to this forum.

    You probably may use any version of Qt provided it has the functionality you are needing. If you are thinking of pure gui applications, you may want to look for an older version. Newer versions tend to have more functionality and are larger. Even so, this may not be generalized.

    More important for you is probably that you have to compile your own version for the embedded platform. Therefore you need to download an archive and configure and compile it.
    [/quote]

    Hi koahing.....

    I have to use latest version of Qt for developing the gui applications and later i need to run those applications on AM1808 processor based platform.
    One more confusion is that the AM1808 based platform will have Linux os so is it necessary that i should install Qt a linux host pc....can i develop apps on Qt installed on windows host pc and then compile it for the target system


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.