[Solved] Problem with remote compiler and extra folder / deploymentfolder

  • Hello!

    I've searched here and there but this problem kept me stuck for a whole day.
    So i need some pointings and helps from you all :( sorry for the trouble.
    I'm a newbie, I'll try to describe it as detail as possible.

    I am using Qt Creator 2.2.0 for Windows, based on Qt 4.7.4.
    Currently I'm creating a test project that uses an external / extra file or folder (deploymentfolders).
    I'm trying to build this project via Remote Compiler, for MeeGo 1.2 Harmattan target.

    The program simply reads from files/test.txt, and copies it to a label.
    I could've used a QResource for this type of program, but the real program I'm working on needs
    a file where I can change its value at runtime, and AFAIK I can't do that with QRC. ( CMIIW :D )

    The problem before was a confusing error message in compile output:
    @cp: D:/project/filetest/files' andD:/project/filetest/files' are the same file
    make: *** [copydeploymentfolders] Error 1@

    the copydeploymentfolders Error 1 is gone now, thanks to "this thread":http://developer.qt.nokia.com/forums/viewthread/9037.
    However, the deploymentfolders are not deployed into the phone (N9 via Nokia Remote Device Access) after I installed my app.
    In my .pro file, I simply changed the external file source into my own: @unix {
    dir1.files = files/*
    dir1.path = /opt/$${TARGET}
    INSTALLS += dir1
    } else {
    dir1.source += files/*

    Also another thing I noticed, inside the .rar file that QtCreator created before sending it to Remote Compiler,
    I cannot find the external file i want. :S

    Any help is appreciated,
    thank you very much!

  • It appears that I didn't search enough.. x.x
    I have found a thread that's potential for a solution.

    will update. Sorry for the trouble!
    here's the thread: "Link":http://developer.qt.nokia.com/forums/viewthread/9037

    Remote Compiler doesn't seem to package my deploymentfolders; i can't find it inside the device's directory..

  • Solved! I downloaded the newest version of QtCreator and it works well.


Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.