How to use QCA (Qt Cryptographic Architecture) on Ubuntu



  • I use QAC for encryption and decryption of my password. I use the algorithm aes256-cfb. When I entered a key and I validate the if statement (QCA:: isSupported ("aes256-cfb")) returns false. I installed libssl-dev. But nothing.

    Fedora in the if statement (QCA:: isSupported ("aes256-cfb")) returns false if I do not install openssl-dev.

    I installed Ubuntu equivalent. That is, libssl-dev, but it still does not work.

    What is missing?



  • Did you install the appropriate QCA plugins?



  • In my project I compile the sources of QCA and I generate a libQCA.so. I do not want to install manually QCA. This works fine under Fedora. When I install manually QCA, it work under Ubuntu. But that's not what I want.



  • So what do you want instead?



  • When I install my software, the QCA module is installed. The file libQCA.so is created at the same level of the executable software in the directory / usr / share /Software_name. And the directory "crypto" whitch contains the qca-ossl is created. How to whether my QCA is taken into account under ubuntu?



  • I still don't get what you want. "is installed" is a bit too vague to answer quesions! Who installs what? By which means? Unpacking a ZIP, a shell bin script, a native package for the distro in use? Is QCA included in your package or should be installed by resolving package dependencies? Do you ship your own Qt or do you rely on the system's Qt?



  • hi i installed libqca2 by using synaptic manager.. but i m not able to find libqca.so in /usr/lib path(UBUNTU 11.04).


  • Moderators

    Try running "dpkg -L libqca2". It should list all files contained in the package you installed.

    It will not contain libqca2.so (those are in the -dev packages), but it should have libqca2.some.version.so, which should be fine. The actual plugins needed to use QCA might be in separate packages, debian (and thus ubuntu) is splitting up everything into multiple packages.



  • Qt Library Paths:
    /usr/lib/qt4/plugins
    /usr/local/bin
    plugin: Checking Qt static plugins:
    plugin: (none)
    plugin: Checking Qt Library Path: /usr/lib/qt4/plugins
    plugin: libqca-ossl.so: (class: opensslPlugin) loaded as qca-ossl
    plugin: libqca-ossl.so.debug: not a library, skipping
    plugin: Checking Qt Library Path: /usr/local/bin
    plugin: (No 'crypto' subdirectory)
    Available Providers:
    qca-ossl
    This product includes cryptographic software written by Eric Young
    (eay@cryptsoft.com)
    *sha1
    *sha0
    *ripemd160
    *md4
    *md5
    *sha224
    *sha256
    *sha384
    *sha512
    *hmac(md5)
    *hmac(sha1)
    *hmac(sha224)
    *hmac(sha256)
    *hmac(sha384)
    *hmac(sha512)
    *hmac(ripemd160)
    *aes128-ecb
    *aes128-cfb
    *aes128-cbc
    *aes128-cbc-pkcs7
    *aes128-ofb
    *aes192-ecb
    *aes192-cfb
    *aes192-cbc
    *aes192-cbc-pkcs7
    *aes192-ofb
    *aes256-ecb
    *aes256-cbc
    *aes256-cbc-pkcs7
    *aes256-cfb
    *aes256-ofb
    *blowfish-ecb
    *blowfish-cbc-pkcs7
    *blowfish-cbc
    *blowfish-cfb
    *blowfish-ofb
    *tripledes-ecb
    *tripledes-cbc
    *des-ecb
    *des-ecb-pkcs7
    *des-cbc
    *des-cbc-pkcs7
    *des-cfb
    *des-ofb
    *cast5-ecb
    *cast5-cbc
    *cast5-cbc-pkcs7
    *cast5-cfb
    *cast5-ofb
    *pbkdf1(sha1)
    *pbkdf2(sha1)
    *pkey
    *dlgroup
    *rsa
    *dsa
    *dh
    *cert
    *csr
    *crl
    *certcollection
    *pkcs12
    *tls
    *cms
    *ca
    plugin: Unloaded: qca-ossl
    

    I m Unable to load qca-ossl plugin.. the above is the trace found when i ran /usr/bin qcatool2 plugins --debug



  • Hi sry the objective of the above post is I m Unable to load qca-ossl plugin.. the above is the trace found when i ran /usr/bin qcatool2 plugins —debug


  • Moderators

    You did install the libqca plugins, didn't you?



  • You have to install openSSL. If you develop, install openSSL-devel. You can download here the version witch is compatible of your plate forme: http://packages.ubuntu.com/fr/hardy/qca-dev and http://darkstar.ist.utl.pt/ubuntu/archive/ubuntu/pool/universe/q/qca/


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.