Phonon::FatalError 0x80040266



  • Hello. I’ve decided to write a music player.
    But then I faced a problem. Some of mp3 files can’t be played.
    On studying some documents I found out that a Phonon::MediaObject has a public function errorType() and errorString().
    Result of the first one is FatalError and the second one - "Contacts could not be connected because they do not support the same transport. (0x80040266)."

    I thought I was doing something in a wrong way so I’ve decided to open the "Music Player" from QtDemo(I have Qt 4.7.4 for VS2008). When opening the same file the same error message appeared.
    When I opened the file via Windows Media Player 12(Windows7 x64) it started playing.
    I believe the problem might be with codecs. But nothing from the list below would work out:

    K-Lite Codec Pack 8.0 Basic
    K-Lite Codec Pack 8.0 Standart
    K-Lite Codec Pack 8.0 Full
    K-Lite Codec Pack 8.0 Mega
    K-Lite Codec Pack 8.0 64bit
    XP Codec-Pack 2.5.1
    Windows 7 Codec Pack 3.4.0

    I was up to build a graph and used graphedit.exe(Microsoft Windows SDK v7.0) for this purpose, but I got the same error.
    Using CodecInstaller I finally saw the information about the codec. It just read: TabLib.Mpeg.AudioHeader(MPEG Version 1 Auduo, Layer 3) - simple mp3.

    And to feel completely happy, I run this mp3 via Windows Media Player 9 in Windows XP SP3 x86(just installed in virtualbox).

    I do not know how to solve this problem. Could you please help me.
    Link to "bad" mp3 file: http://www65.zippyshare.com/v/64546985/file.html



  • Up. Surely no one encountered this problem?



  • I've got "The media type of this file is not recognized. (0x80040240)" on this file



  • And now i got: "Can not play the file. The format is not supported. (0x80040265)"

    But WMP9, WMP11, AIMP2, AIMP3 and GOM Player still work with this song...



  • I'm experiencing the same troubles here on my machine (Qt 4.8.0 / QtCreator 2.4.0, Windows 7 32 bit). I've no codec packs or what so ever installed.

    I get the 0×80040266 error, and I can't figure out why. The MP3s seem not to be "broken" - at least according to mp3val, and all other players play them fine, and the files even play with Phonon on Linux (Qt 4.8.0 as well) - windows fails.

    Could be that this is a phonon bug ..



  • Here's my error message on MANY mp3 files under Windows 7:

    Pins cannot connect due to not supporting the same transport. (0x80040266)

    Looks like a Windows Phonon bug from here. Same exact files play great in osx and linux using the same Qt code. I've seen that the clementine music player switched from phonon to gstreamer to fix this issue. I'd really rather not do that!!

    Here is Microsoft's (crummy) explanation:

    VFW_E_NO_TRANSPORT
    0x80040266
    Pins cannot connect because they don't support the same transport.
    For example, the upstream filter might require the IAsyncReader interface,
    while the downstream filter requires IMemInputPin.

    From here:
    http://msdn.microsoft.com/en-us/library/windows/desktop/dd375623(v=vs.85).aspx



  • I wanted to add that this does not appear to be hardware-specific.

    It is happening on both of my development boxes. One is an ASUS P8P67LE mobo with an i5, the other is a Macbook Pro using bootcamp to boot into Windows.

    Any help would be appreciated. Let me know if I can provide more information. Without a solution soon I will have to start digging into gstreamer, sigh... or are we supposed to be switching to Qt Mobility or whatever..?

    Thanks in advance for any help.



  • I'm having the same problem on a windows 7 64 bit VM machine. I can play some mp3's but not all. I downloaded an mp3 from amazon that did not work.

    Windows media player plays the mp3 fine.

    Not using phonon and trying to create the graph myself it did not work either.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.