Nominate our 2022 Qt Champions! compatibility with

  • I have a Fedora Core release 3 based build machine on which I have QT 3.3.4 libraries and I can build fine my qt application.
    Now I need to use qt 3.3.8 libraries, so I copied the .h files and qt libraries and qmake, moc, ui, from the SLES 11 sdk + install dvd to my build machine and tried to compile my application, but getting this eror:
    uic: /lib64/tls/ version GLIBC_2.4' not found (required by uic: /lib64/tls/ versionGLIBC_2.4' not found (required by

    In my build machine I have only

    So my question:
    If I need to use (coming from qt 3.3.8 package) is it mandatory to have 2.4 (or above) ?

    When I checked qt3.3.8 package dependency I saw:
    rpm -qR qt3-3.3.8b-88.21

    There are listed version 2.2, 2.3 and 2.4.
    Is there way to make it work with 2.3 ?
    Thanks in advance !

  • Fedora Core 3 is from November 2004, SLES 11 from March 2009.
    It's most likely that those distros are not binary compatible in regard to gcc and libc.

    You will either have to search for 3.3.8 packages for the Fedora box or grab the sources and build it yourself. You must not use the SLES 11 package.

Log in to reply