Nominate our 2022 Qt Champions!

Qt5GLib-2.0 development package not found

  • I have all of these packages sudo installed onto my ubuntu machine but for some reason I still am getting errors for almost all of them saying the package cannot be found. Do I have to move them into the project folder or link them using the paths somehow?

    CONFIG += link_pkgconfig
    TEMPLATE = app
    unix:!macx {
        PKGCONFIG += Qt5GLib-2.0
        PKGCONFIG += Qt5GStreamer-1.0
        PKGCONFIG += Qt5GStreamerUi-1.0
        PKGCONFIG += Qt5GStreamerUtils-1.0
        PKGCONFIG += gstreamer-1.0
        PKGCONFIG += gstreamer-app-1.0
        PKGCONFIG += glib-2.0
        INCLUDEPATH += /usr/share/qt4/mkspecs/linux-g++
        INCLUDEPATH += Qt5GStreamer-1.0
        INCLUDEPATH += /usr/Documents/qt-gstreamer-1.2.0/build/src/QGlib
        INCLUDEPATH += /usr/Documents/qt-gstreamer-1.2.0/src/QGst
        LIBS += -L./lib -L/usr/local/lib -lQt5Gui -lQt5Network -L/usr/lib/i386-linux-gnu -lQt5Core -lpthread -lgobject-2.0 -lglib-2.0 -lQt5Concurrent -lNBiometricClient -lNBiometrics -lNDevices -lNMedia -lNCore -lNLicensing -lsqlite3

  • Lifetime Qt Champion


    Are you sure the casing is correct ?
    Did you install the development package of these libraries installed ?
    If your run pkg-config on the command line, can you get the information about these packages ?

  • When I run pkg-config and then the package name nothing will come up for them

  • Lifetime Qt Champion

    Then Qt won't do miracle for that. Do you have any .pc files for these libraries ?

  • Figured it out from your comment, I had the package itself but not the development one, installing that I believe fixed it

Log in to reply