Blank QML Designer

  • Hello guys,

    I logged on my PC today and opened my current project (Qt Quick Project), and the designer view is simply blank; the app runs without error, but the designer simulator simply does nothing. The strange thing is, it was working yesterday on both of my Qt Creator IDEs on Windows and Mac, and now even previous versions of my program refuse to load on the Designer.

    If I create a new Qt Quick project, it's still blank! Does anyone have any ideas what could cause this?


    I noticed that General Messages is throwing an error for clang, but I'm not sure if that affects QML or just the C++ compilers. The program is an app, but I've also tried a Windows kit and the same thing happens.

    I also thought it might be the QML Emulation layer settings, as the app runs perfectly if I run it, it's just I can't see anything in the designer view.



    In addition to this, I'm also getting "warningless warnings" whenever I click from code view to design view for QML. If I click on Go to warnings, it just opens the code, without displaying where the error is coming from.


    Please let me know if you have any ideas what could be causing this! I am also unable to open the Maintenance Tool to try and verify/repair the files.

  • UPDATE: Other kits work perfectly, it's just my Android kit that cannot load the QML Creator Designer mode properly!

Log in to reply