Important: Please read the Qt Code of Conduct -

How to install qt version?(for Linux)

  • I set qt creator. After installation, I can not start the project, because they require the introduction of kits.
    Also, I can not run the examples (, because the manual says that this requires versions. How to install versions?

    It says ( that (with manual installation) need to insert the installation file, but I don’t have it. Where to get it? I downloaded qt 5.13.0 from the official site but could not find the file there qmake.
    Please help me. Sorry for my bad english...

  • Lifetime Qt Champion

    Hi and welcome to the forums.

    What platform is this on ?

    (looks like your are on linux)
    Did you also install gcc etc ?
    sudo apt-get install build-essential (ubuntu)
    or similar for your platform.

    Normally the kits are auto made.

    But if it can't find the toolchain files,
    there is no kits.

  • @mrjj Hello. Thank you for answering my question. But I already have gcc and build-essential the latest version installed. I checked everything again ... Maybe something else needs to be installed?

  • Lifetime Qt Champion

    Hi normally not. if you have the tool chain then it normally get kits.
    if you open shell and type qmake does it run?

  • @mrjj Yes. started and it appeared:

    QMake has two modes, one mode for generating project files based on
    some heuristics, and the other for generating makefiles. Normally you
    shouldn't need to specify a mode, as makefile generation is the default
    mode for qmake, but you may use this to test qmake on an existing project

    -project Put qmake into project file generation mode
    In this mode qmake interprets files as files to
    be built,
    defaults to *; *; *; *.ts; *.xlf; *.qrc
    Note: The created .pro file probably will
    need to be edited. For example add the QT variable to
    specify what modules are required.
    -makefile Put qmake into makefile generation mode (default)
    In this mode qmake interprets files as project files to
    be processed, if skipped qmake will try to find a project
    file in your current working directory

    Warnings Options:
    -Wnone Turn off all warnings; specific ones may be re-enabled by
    later -W options
    -Wall Turn on all warnings
    -Wparser Turn on parser warnings
    -Wlogic Turn on logic warnings (on by default)
    -Wdeprecated Turn on deprecation warnings (on by default)


    • You can place any variable assignment in options and it will be *
    • processed as if it was in [files]. These assignments will be *
    • processed before [files] by default. *
      -o file Write output to file
      -d Increase debug level
      -t templ Overrides TEMPLATE as templ
      -tp prefix Overrides TEMPLATE so that prefix is prefixed into the value
      -help This help
      -v Version information
      -early All subsequent variable assignments will be
      parsed right before default_pre.prf
      -before All subsequent variable assignments will be
      parsed right before [files] (the default)
      -after All subsequent variable assignments will be
      parsed after [files]
      -late All subsequent variable assignments will be
      parsed right after default_post.prf
      -norecursive Don't do a recursive search
      -recursive Do a recursive search
      -set <prop> <value> Set persistent property
      -unset <prop> Unset persistent property
      -query <prop> Query persistent property. Show all if <prop> is empty.
      -qtconf file Use file instead of looking for qt.conf
      -cache file Use file as cache [makefile mode only]
      -spec spec Use spec as QMAKESPEC [makefile mode only]
      -nocache Don't use a cache file [makefile mode only]
      -nodepend Don't generate dependencies [makefile mode only]
      -nomoc Don't generate moc targets [makefile mode only]
      -nopwd Don't look for files in pwd [project mode only]

    I installed qt5 again. I got it in versions but they require installing qmlscene. I installed it, but still they demand to install it and to create a new project I still can not.


  • Lifetime Qt Champion

    So it works now for a default GUI project?

    • but they require installing qmlscene. I installed it, but still they demand to - install it and to create a new project I still can not.

    Hi. who wants qmlscene ?
    qmlscene is external program so not really sure what you mean.
    Do you have some project you download that uses QML and you try to compile
    it and it ask for qmlscene ?

    This is how my kit look like on linux
    alt text

  • @mrjj I can not create a single project. Everywhere some kind of kits are required which I do not have. I don’t understand where to get them.

    I have a mistake 6.png , so I decided that I need to install qmlscene 7.png

    I don't know if i need qmlscene or not. I just want all the work and I could create projects...

  • Lifetime Qt Champion

    Its a bit hard for me to see what you got due to the language of the screenshots.

    In any case, it must be due to the location of qmake / gcc etc.

    You must manually point the kit to qmake, the gcc and debugger where they are located in your system.

    What linux is that btw ?

    ps. you can ignore qmlscene is not needed for anything compiler related.

  • @mrjj oh sorry..
    qmake, comppilera and debuggers automatically detected already.
    I tried to create a new kit, but I do not have CMake and did not understand where to get it

    it is not detected automatically

    I use Debian, but I tried installing qt in Windows 8 and there was the same problem

  • Lifetime Qt Champion

    it really looks ok now.
    So if you generate a new default GUI app. it still cannot compile?

    • installing qt in Windows 8 and there was the same problem

    Unless you choose a MinGW Qt, you must install visual studio manually.

  • @mrjj I can’t even create a project. Any project. On the way to the creation of the project, it is required to introduce some kit. I can not continue to create a project without kit. 45656.png

    On windows I already have a visual studio.
    I’ve been trying to solve this problem for several days now. Please tell me, is this generally solved or am I suffering in vain?

  • Lifetime Qt Champion

    Its generally fixed by manually filling out the kits/compiler as described in those 2 docs i linked.

    I dont understand why you cannot select the Default Desktop kit that is shown.
    It seems valid as no yellow mark.

    On windows its rarely an issue i have seen if using the correct visual studio Qt.

    If using mingw Qt on Windows it should just works out of the box as all is included.

    You do expand the Qt branch in installer and only installed the needed Qt versions ?

  • Lifetime Qt Champion

    @kisa How did you install Qt? /usr/lib/qt5 is most probably Qt from your distribution. Did you use Qt online installer?

Log in to reply