Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt update 5.15, building now stuck launching Debugger



  • Today I switched my project to Qt 5.15 and when I launch the debugger I get the message:

    07:25:31: Debugging starts
    QML debugging is enabled. Only use this in a safe environment.
    "-qmljsdebugger=port:49799,block,services:DebugMessages,QmlDebugger,V8Debugger,QmlInspector.xml" does not exist!: No such file or directory
    

    My project doesn't use QML and it never launches the application, the progress bar bottom right is stuck at what appears to be 25% with the text "Launching Debugger"

    My '.pro' file:

    #
    # Project created by QtCreator 2018-10-15T09:17:31
    #
    #-------------------------------------------------
    
    QT       += core gui sql widgets qml
    
    TARGET = XMLMPAM
    TEMPLATE = app
    
    ####### Custom Variables
    EXPORT_QMAKE_MAC_SDK = macosx
    EXPORT_QMAKE_MAC_SDK_VERSION = 10.15
    EXPORT_VALID_ARCHS = x86_64
    
    # The following define makes your compiler emit warnings if you use
    # any feature of Qt which has been marked as deprecated (the exact warnings
    # depend on your compiler). Please consult the documentation of the
    # deprecated API in order to know how to port your code away from it.
    DEFINES += QT_DEPRECATED_WARNINGS
    
    # Uncomment to include XML debug information
    #DEFINES += DEBUG_XML
    DEFINES += DEBUG_SCRIPT
    DEFINES += DEBUG_SIGNALS
    #DEFINES += DEBUG_THREADS
    
    # You can also make your code fail to compile if you use deprecated APIs.
    # In order to do so, uncomment the following line.
    # You can also select to disable deprecated APIs only up to a certain version of Qt.
    #DEFINES += QT_DISABLE_DEPRECATED_BEFORE=0x060000    # disables all the APIs deprecated before Qt 6.0.0
    
    CONFIG += c++11
    CONFIG += sdk_no_version_check
    #CONFIG += QT_DEBUG_PLUGINS
    #CONFIG += qml_debug
    
    SOURCES += \
            clsFileThread.cpp \
            clsJSON.cpp \
            clsMainWnd.cpp \
            clsQtComboBox.cpp \
            clsQtFrame.cpp \
            clsQtLabel.cpp \
            clsQtLineEdit.cpp \
            clsQtPushBtn.cpp \
            clsQtTextEdit.cpp \
            clsSignal.cpp \
            clsScriptHelper.cpp \
            clsSocketThread.cpp \
            clsThread.cpp \
            XMLMPAM.cpp
    
    HEADERS += \
            clsJSON.h \
            clsMainWnd.h \
            clsFileThread.h \
            clsQtComboBox.h \
            clsQtFrame.h \
            clsQtLabel.h \
            clsQtLineEdit.h \
            clsQtPushBtn.h \
            clsQtTextEdit.h \
            clsScriptHelper.h \
            clsSignal.h \
            clsSocketThread.h \
            clsThread.h
    
    FORMS += \
            clsMainWnd.ui
    
    # Default rules for deployment.
    qnx: target.path = /tmp/$${TARGET}/bin
    else: unix:!android: target.path = /opt/$${TARGET}/bin
    !isEmpty(target.path): INSTALLS += target
    
    RESOURCES += \
        clsmainwnd.qrc
    

    I need the "qml" on the QT line in order to use QJSEngine, although I don't use QML in my project.



  • @SPlatten said in Qt update 5.15, building now stuck launching Debugger:

    QML debugging is enabled

    Hello, why you don't disable QML debugging?
    ==> Projects/Run/Debugger settings and uncheck "Enable QML"
    e4506ff9-0562-4a32-bd6c-8a0e9fa97b1c-image.png



  • @SPlatten said in Qt update 5.15, building now stuck launching Debugger:

    QML debugging is enabled

    Hello, why you don't disable QML debugging?
    ==> Projects/Run/Debugger settings and uncheck "Enable QML"
    e4506ff9-0562-4a32-bd6c-8a0e9fa97b1c-image.png



  • Thank you, I'll give it a go...I haven't had to do this prior to Qt 5.15, that works!


Log in to reply