Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Noob Question around Qt Creator



  • I am at the point where I can select Components. What is the reason to install multiple components?Speed Test Solitaire essay writer

    For example, should I only install Qt 5.15.0? Why would I want to install older ones like Qt 5.13.2 for example?

    Also if I only install Qt 5.15.0 would I need to install Qt 5.13.2 to edit a program that was made with Qt 5.13.2?


  • Moderators

    What is the reason to install multiple components?

    Sometimes you may use different Qt versions on different platforms. Sometimes you may work on several different projects, each using different Qt version. Sometimes you may want to test your app on several Qt versions. Sometimes your user will tell you about a bug when your app is run with a particular Qt version. Sometimes you need to check if your app compiles with several Qt versions.

    There are really many reasons :-)

    For example, should I only install Qt 5.15.0?

    If you don't have a reason to install another version, then don't :-) You will be perfectly fine with only 5.15.0.

    Why would I want to install older ones like Qt 5.13.2 for example?

    I've already answered that.

    Also if I only install Qt 5.15.0 would I need to install Qt 5.13.2 to edit a program that was made with Qt 5.13.2?

    No, Qt is backward and forward compatible (well, with some exceptions).


Log in to reply