Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

No background on QtQuick Controls with self compiled Qt



  • Hi everyone!

    I'm working with Qt 5.14.2 and my program has a combobox which looks like this on Ubuntu 18.04.3:

    good.PNG

    We were having troubles with OpenSSL on some target systems, therefore we compiled Qt with -openssl-linked.
    With our compiled version of Qt the combobox looks like this:

    bad.PNG

    It kind of seems the background is missing. Also the buttons are just plain white.
    The source code hasn't changed and the Qt version is also the same.

    I've compiled Qt and the program on the ubuntu:xenial docker image.
    I've used the following configure options:

    ./configure -opensource -confirm-license -release
    -platform linux-g++-64
    -make libs
    -nomake examples -nomake tools -nomake tests
    -opengl desktop
    -qt-xcb
    -qt-zlib
    -qt-pcre
    -qt-libjpeg
    -qpa xcb
    -skip qt3d
    -skip qtactiveqt
    -skip qtandroidextras
    -skip qtcharts
    -skip qtconnectivity
    -skip qtdatavis3d
    -skip qtdoc
    -skip qtgamepad
    -skip qtlocation
    -skip qtlottie
    -skip qtmacextras
    -skip qtmultimedia
    -skip qtnetworkauth
    -skip qtpurchasing
    -skip qtquick3d
    -skip qtremoteobjects
    -skip qtscript
    -skip qtscxml
    -skip qtsensors
    -skip qtserialbus
    -skip qtserialport
    -skip qtspeech
    -skip qtsvg
    -skip qttools
    -skip qttranslations
    -skip qtvirtualkeyboard
    -skip qtwayland
    -skip qtwebchannel
    -skip qtwebengine
    -skip qtwebglplugin
    -skip qtwebsockets
    -skip qtwebview
    -skip qtwinextras
    -skip qtx11extras
    -skip qtxmlpatterns
    -prefix $QT5PREFIX
    -no-rpath
    -no-feature-relocatable
    -openssl -openssl-linked
    OPENSSL_PREFIX=$OPENSSL_DIR
    OPENSSL_INCDIR=$OPENSSL_DIR/include
    OPENSSL_LIBDIR=$OPENSSL_DIR/lib

    I've tried to omit -qt-xcb or using -opengl es2 but to no avail.
    Have you seen anything like this before? Any idea what I could try next?
    Any help is much appreciated!

    Best regards,
    Manfred



  • Solved the problem. Without -platform linux-g++-64 it works.



  • Solved the problem. Without -platform linux-g++-64 it works.


Log in to reply