Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt Webengine 5.6.3 is not being built.



  • Hi,

    I tried to build Qt Webengine along with Qt 5.6.3 sources but it is not being built.

    ./configure -v -opensource -confirm-license -make libs -release -shared -sysroot /home/target/ti-processor-sdk-linux-rt-am335x-evm-05.03.00.07/linux-devkit/sysroots/armv7ahf-neon-linux-gnueabi -device arm-linux-gnueabihf-g++ -device-option CROSS_COMPILE=/home/target/ti-processor-sdk-linux-rt-am335x-evm-05.03.00.07/linux-devkit/sysroots/x86_64-arago-linux/usr/bin/arm-linux-gnueabihf- -reduce-exports -optimize-size -no-gtk -no-use-gold-linker -qt-libjpeg -qt-zlib -qt-libpng -system-sqlite -no-xcb -no-cups -no-opengl -no-qml-debug -skip qt3d -skip qtactiveqt -skip qtandroidextras -skip qtcanvas3d -skip qtcharts -skip qtconnectivity -skip qtdatavis3d -skip qtdoc -skip qtgamepad -skip qtgraphicaleffects -skip qtimageformats -skip qtnetworkauth -skip qtlocation -skip qtmacextras -skip qtpurchasing -skip qtmultimedia -skip qtquickcontrols -skip qtquickcontrols2 -skip qtremoteobjects -skip qtscript -skip qtscxml -skip qtsensors -skip qtserialbus -skip qtserialport -skip qtspeech -skip qttools -skip qtwayland -skip qtwebsockets -skip qtwebview -skip qtwinextras -skip qtandroidextras -skip qtx11extras -skip qtxmlpatterns -nomake tools -nomake tests -nomake examples -no-compile-examples -no-iconv -dbus -fontconfig -system-freetype -ssl -qt-pcre -no-pch -recheck-all -DQT_ARCH_ARM

    Since QtWebengine 5.6.3 depends on Qt Declarative and Qt Webchannnel, these modules are not skipped. However, Qt Webengine is not built as part of Qt 5.6.3 sources.

    Having found in the configuration that QtWebegine needs opengl es2 to include Qt dependencies like quick and webchannel, added opengl es2 instead of -no-opengl in the configure line but Qt Webengine is not being built.

    Building QtWebengine as a separate module after installing Qt libraries give the following errors with qmake and make:

    /target/qt-everywhere-opensource-src-5.6.3/qtwebengine$ qmake
    Info: creating cache file /home/target/qt-everywhere-opensource-src-5.6.3/qtwebengine/.qmake.cache
    Running configure tests
    Checking for khr... yes
    Checking for libvpx... no
    Checking for snappy... no
    Checking for srtp... no
    System zlib or minizip not found. Using Chromium's copies.
    System jsoncpp not found. Using Chromium's copy.
    System opus not found. Using Chromium's copy.
    Protobuf compiler not found. Using Chromium's copy of protobuf.
    Compatible system libvpx not found. Using Chromium's copy.
    System libsrtp not found. Using Chromium's copy.
    System snappy not found. Using Chromium's copy.
    Certificate handling.............. Using bundled BoringSSL
    ICU............................... Using internal copy (Default, force system ICU with WEBENGINE_CONFIG+=use_system_icu)
    FFMPEG............................ Using internal copy (Default, force system FFMPEG with WEBENGINE_CONFIG+=use_system_ffmpeg)
    Proprietary codecs (H264, MP3).... Not enabled (Default, enable with WEBENGINE_CONFIG+=use_proprietary_codecs)
    Geolocation....................... Not enabled (Requires Qt Positioning module)

    make:
    Unknown option 'include'.
    [11153/11247] ACTION QtWebEngineCore: moc_gl_context_qt.cpp_ce8e5f335501de3b8e6f5fdd88bd4f81
    FAILED: cd /home/target/qt-everywhere-opensource-src-5.6.3/qtwebengine/src/core;
    Unknown option 'include'.
    ninja: build stopped: subcommand failed.
    Makefile.gyp_run:565: recipe for target 'invoke_ninja' failed
    make[3]: *** [invoke_ninja] Error 1

    Please let me know if Qt Webengine can be built as part of Qt 5.6.3 sources or as a separate module. If so, any missing dependencies or configure line issue for Qt 5.6.3.


  • Lifetime Qt Champion

    @Ramakanth said in Qt Webengine 5.6.3 is not being built.:

    /target/qt-everywhere-opensource-src-5.6.3/qtwebengine$ qmake

    Are you sure you're calling correct qmake here? You should use absolute path.



  • @jsulm Yes after setting the PATH using export PATH=/home/target/ti-processor-sdk-linux-rt-am335x-evm-05.03.00.07/linux-devkit/sysroots/armv7ahf-neon-linux-gnueabi/usr/local/Qt-5.6.3/bin:$PATH, I run qmake.


Log in to reply