Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt installation folder changed from /home to /opt and now its not listed as a program



  • Hi,

    so weeks ago i installed Qt on my Laptop with Manjaro and on the installation process it wanted to install the program into /home/user/Qt. On Sunday i installed Linux Mint on a workstation i got (wifi driver) and also installed Qt here in /home/user/Qt and everything was fine (and it asked if i want to start after installation).

    Now i wanted to switch this workstation to Debian with KDE, but here it stated that it wants to install Qt in /opt/Qt. Okay, did it, but then it wasn't listed as a program when i searched for it (and no option to start after installation). The only way to start it, was to got into /opt/Qt/Tools/QtC..../qtcreator. So i uninstalled, reinstalled but this time manually into /home/user/Qt but that didn't helped me. Whiped Debian and installed Manjaro on the workstation but same problem on here (+wifi driver wasn't working). Now i had to switch back again to Mint, installer wanted to install into /opt/Qt again, changed that to /hom/..../ and now its working again. But why? What was the problem on Debian KDE, Debian Gnome and Manjaro KDE/Gnome?

    Greets


  • Moderators

    I have no explanation, just some rules of thumb:

    • do not run Qt installer with admin permissions (sudo)
    • do not install to /opt, prefer user dir

    I have never had a problem with that, it easy to install, uninstall, change Qt versions etc.



  • Hi,
    sorry for the late reply my projects are taking up a serious amount of time. So i installed a new VM with Debian on Windows to check up what you have written and indeed the issue was that i ran it with root permission. As soon as i ran it as a user it installed into the home directory and everything was perfectly fine (and the app showed in my app menue).

    Thanks for the help!


  • Moderators

    Great, happy coding :-)



  • @marcopasta said in Qt installation folder changed from /home to /opt and now its not listed as a program:

    everything was perfectly fine

    great, so please don't forget to mark your post as solved. Thanks.


Log in to reply