Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QtGraphicalEffects components cannot be created in Qt Design Studio/Qt Creator community version



  • Hey there, I'm a relative newbie to QML and Qt Quick, and I'm using Qt Design Studio 1.4.0, the community (open source) edition, on a Mac.

    When building a QML form, I tried to put the following bit into the code:

    FastBlur {
        id: blur
        height: 200
        width: parent.width
        radius: 40
        opacity: 0.5
    
        source: ShaderEffectSource {
            sourceItem: pane
            sourceRect: Qt.rect(0, 0, blur.width, blur.height)
        }
    }
    

    but the item in the navigator shows a warning icon, and is underlined in red, and on hover shows the following warning message:

    "Component with path /...user applications dir.../QtDesignStudio-1.4.0-community/qt5_design_studio_reduced_version/qml/QtGraphicalEffects/FastBlur.qml could not be created."

    That file is certainly there, and I don't see anything wrong otherwise...anyone know why I am unable to create one of these components successfully? I noticed that I can sometimes kick the editor into not complaining by adding other QtGraphicalEffects components which don't cause the error, and then deleting them...somehow that occasionally tricks it into thinking there's no longer a warning.



  • A tiny bit of followup: I tried replicating this in Qt Creator 4.12.0, to see if it was just a Qt Design Studio issue, but it happens there as well. The warning message is more detailed in Qt Creator, however.

    Here's what it says in Qt Creator when I hover over the FastBlur component that it is warning about:

    Component with path /Users/<username>/Qt/5.14.2/clang_64/qml/QtGraphicalEffects/FastBlur.qml could not be created.
    
    file:///Users/<username>/Qt/5.14.2/clang_64/qml/QtGraphicalEffects/qmldir/: plugin cannot be loaded for module ".Users.<username>.Qt.5.14.clang_64.qml.QtGraphicalEffects": Module namespace 'QtGraphicalEffects' does not match import URI '.Users.<username>.Qt.5.14.clang_64.qml.QtGraphicalEffects'
    

    I am still unable to figure out exactly what it is trying to tell me there, but it's at least a little more info.

    The path to the FastBlur.qml is valid, the files exist in the right place.



  • Still hoping for some further info on this from the community, but I did find the following things:

    1. Even though the warning is there, when I actually preview the qml the FastBlur component is there and appears to be working.

    2. It seems like FastBlur is the only one of the QtGraphicalEffects which gets this warning? Or, at least, when I added other QtGraphicalEffects to the QML, it didn't give that warning for any of them.

    So maybe this is a bug or ignorable warning? I'd love to know if anyone else has seen this and has any understanding of why it is happening.



  • Hello,

    I have an almost similar issue in creator (for which I created a post on the forum), but with all the components from QtGraphicalEffects, they work at runtime, but I can't get the preview in creator form editor. I also have the little yellow triangle icon warning.
    In design studio, it works fine in all aspects. Although there I'm using qt.studio.effects, which in the end is nothing more than a wrapper with Item for convenience of the QtGraphicalEffects.
    As I pointed out in my post, I found this bug tracker:
    https://bugreports.qt.io/browse/QTBUG-57205
    Maybe it can give you a hint.
    I'll be following if you find a solution.
    Best regards.


Log in to reply