Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt.qpa.xcb



  • Hi. I'm new to Qt and am trying to load paraview in Linux. Given the hundreds of posts on the Qt file Qt.qpa.xcb loading issue, Why hasn't this problem been fixed ? Or maybe it has ?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    From experience on other topics like the MySQL/PostgreSQL drivers or OpenSSL, many times when a the same question comes again and again and seems not fixed, if you take the time to look at bit further, you will see several patterns:

    • people not having searched the forum
    • people not reading the documentation
    • people using the documentation for a different and outdated version of Qt
    • people using a different series of Qt (4 vs 5)
    • people following the instructions for a different platform
    • people following outdated articles (some might be old but still valid but that's not always the case)
    • people using an outdated distribution wanting to use an fully up to date Qt version

    As for your issue:

    • What version of Qt are you using ?
    • On what distribution ?
    • How did you install it ?
    • Are you using a pre-built binary of that application ?

Log in to reply