Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Cross compilation for RPI3 under Windows



  • Hello,

    I am trying to have a cross compilation environement for RaspberryPi 3 under Windows 10. I read and tried many tutorials and weird things but I cannot figure out. I have the impression that the configure line change every Qt version.
    I tried to use native commande line and MSYS2, several Qt version, many differents arguments and modify some qmake.conf files.

    For now, I am working with :

    • Qt 5.14.2 sources from MaintenanceTool.exe
    • SysGCC RPI toolchain from here (GCC 8.3.0)
    • SysGCC MINGW64 toolchain from here (GCC 9.1.0)
    • My sysroot folder on Windows host is synchronized with my RPI.

    My command line is :

    ..\Src\configure.bat -platform win32-g++ -device linux-rasp-pi3-g++ -release -opengl es2 -sysroot C:/SysGCC/raspberry/arm-linux-gnueabihf/sysroot -prefix /usr/local/qt5 -device-option CROSS_COMPILE=arm-linux-gnueabihf- -opensource -confirm-license
    

    From Qt documentation here and here, my command seems to be correct but I get the error :

    Running configuration tests...
    Checking for machine tuple... yes
    Checking for valid makespec... yes
    Checking for target architecture... Project ERROR: Could not determine target architecture. See config.log for details.
    

    I don't know how to upload the config.log file to the post but there are some compilation errors of arch.cpp related to system include files in RPI toolchain so I guess that I don't configure it well related to my toolchain.

    Thank you for your help,

    Marthi


Log in to reply