Can't Launch Designer w/ Anaconda 3

  • Hello everyone,

    I know there are a few bug reports detailing information similar to this but I can't seem to get anything to work. Designer used to work until it all of a sudden it wouldn't launch and it's not showing up under the Task Manager either.

    What I have tried:
    -Uninstalling Anaconda and downloading the standalone which would work on the first try but any tries after that I would run into the same issue.
    -Removing the qt5WebEngine dll files with no success.
    -Downloading directly through pyqt-tools with pip and I am getting the same results.
    -Tried from the command line, Anaconda command line, executable in pip download folder.

    Everything used to be fine so I'm not sure what changed. Also strange, that periodically I can get it to run once but then it will not launch at all after that. My next step is to reformat but wanted to try reaching out first.

    Any insight is greatly appreciated.

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What version of conda are you using ?
    On what OS ?
    Did you had any major update done recently ?

  • Thank you for the help.

    -Windows 10 Enterprise 64 bit
    -Anaconda 3 Version 2020.2
    -I am sure I have had updates. I haven't run Designer on this computer for a few months although my other Windows computers with almost the exact same setup run the Designer fine still. Put in a work ticket to see if something is blocking it I can't see.

  • Lifetime Qt Champion

    Try starting design from the command line with the QT_DEBUG_PLUGINS environment variable set to 1. It might give you some clues about what is happening.

  • Going through the command line, not seeing any feedback. I'm worried I didn't set the variable correctly though, didn't see much info on doing it differently from the command prompt. I'm not seeing any debug info and it's still not launching.

    (base) C:\Users\SackLunch>set QT_DEBUG_PLUGINS=1
    (base) C:\Users\SackLunch>designer.exe
    (base) C:\Users\SackLunch>

  • Lifetime Qt Champion

    Did you check where this executable is located ? You might be launching something different with the same if it's found earlier in the paths configured in PATH.

  • @SGaist I have either been changing to the directory or doing a 'where designer.exe' to double check.

    What is really strange is that I can now get designer.exe to launch but the only way I can do it is if I launch designer.exe as soon as the computer boots and before other apps initialize on start up. All the other Qt tools launch fine at any time except for designer.exe.

    If I wait too long after startup, some program seems to be interfering with designer.exe from launching. I have zoom, dropbox, and a few other programs launch so I'm wondering if it's one of those. Anyone else heard of issues like this? Most recent programs for me would be Zoom and Kepware OPC server.

  • Lifetime Qt Champion

    Can you disable them to see which one triggers that behaviour ?

  • @SGaist Yes, thank you for following up. I removed Kepware OPC Server and it seems to have resolved the issue.

    Thank you all for the help!

  • Lifetime Qt Champion

    I wonder what it does that has such implications...

    In any case, since you have it working now, please mark the thread as solved using the "Topic Tools" button or the three doted menu beside the answer that you deem correct so that other forum users may know a solution has been found :-)

  • Looks like I'm still having problems now. It was fine for a few days where it would open with no issues and now I'm back to not being able to open Designer at all.

    Not sure what's causing this and I'm having issues with the debug flag to get debug information to output.

    Any direction to looking into this is appreciated.

  • Lifetime Qt Champion

    Did you install something new ? Got your PATH modified ?

Log in to reply