Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QMake not invoking uic for form files.



  • Folks,
    I am migrating a build from QT 4 on RHEL 6.10 (using qmake 2.01a) to QT 5 on RHEL 8.1 (using qmake 3.1). We develop our code/forms using eclipse, but do production builds with a command line script. In the script we invoke qmake to generate the makefiles, then invoke make to do the build.

    What is happening is that in QT5, the makefile generated by qmake is NOT doing any uic invokes to compile the forms. I have compared the makefiles generated in both environments and while the QT4 generated makes files show dependencies to the generate ui_XXX.h files, and invoke uic to created them from the files specified in the FORMS variable.

    Is there something new in QT5's qmake I have to specify to get the forms compiled ? I looked through the qmake manual in the QT5 documentation and did not see anything.

    Thanks,
    Dale Pennington


  • Moderators

    There is nothing new/ changed in qmake about generating UI headers.

    • Do you include widgets module?
    • Have you tried with some simple test app, if UI generation works at all in your new environment?


  • No I had not included widgets. That turned out to be the solution. Apparently if widgets is not included, the FORMS are ignored.

    Thanks,
    Dale Pennington



  • @DalePennington said in QMake not invoking uic for form files.:

    That turned out to be the solution

    Is your issue solved then? If so, please don't forget to mark your post as such!



  • Had to figure out where the marker was hidden


Log in to reply