Simple QT Application don't run on embeeded board ARM



  • Hi
    I wrote this application and compiled it to arm, when I try to run the application on the board
    ./test –qws, I don’t see any windows created and I get this error message: could not initialize virtual console switching.

    The board as only screen connected it no (Keyboard or mouse)
    @
    class MyWidget : public QWidget
    {
    public:
    MyWidget(QWidget *parent = 0);
    };

    MyWidget::MyWidget(QWidget *parent)
    : QWidget(parent)
    {
    }

    int main(int argc, char *argv[])
    {
    QApplication app(argc, argv);
    MyWidget widget;
    widget.show();
    return app.exec();
    }
    @

    [edit: code highlighted / Denis Kormalev]



  • Witch board are you using?
    Do you see something in the monitor before running the application?



  • Hi
    Nvidia arm-tegra board.
    The X server is loaded and i see an X11 application running.
    I also used xeyes app and it worked.



  • So I don't know, I only used BeagleBoard without X server.

    I think that if an OS use X server, the application doesn't need -qws to start.

    Try to stop X server and execute the application as you done:

    @
    ./test –qws
    @



  • I use xM BeagleBoard too, but i have the same problem with the error code: could not initialize virtual console switching!!!!

    Have you solved your problem!?!?!

    Thanks a lot!


  • Lifetime Qt Champion

    IIRC, when you have an X server running, you won't be able to run an application with qws.

    Two solutions for you:

    1. Build your application with a Qt that was built to use X11 (or Xorg) and use it like you would on your desktop machine.

    2. Don't start the X server on the target and run with -qws


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.