Important: Please read the Qt Code of Conduct -

RPI3B+ QtQuick.VirtualKeyboard failed to extract plugin

  • Hi,

    I'm developping a project on an RPI 3B+ with qt5 creator installed from repo:

    sudo apt-get install qt5-default
    sudo apt-get install qtcreator

    I was able to run some basic code with windows and buttons, however when I started to play with virtualkeyboard an error occured and I don't know how i'm supposed to manage it...


    With QT creator launched on the RPI, create a new project with virtualkeyboard.
    I used "Desktop" by default for the compile tools. (same as I used before)
    A project named test is created where 3 files are included:

    QT +=quick
    CONFIG += c++11
    SOURCES += \
    RESOURCES += qml.qrc
    # Additional import path used to resolve QML modules in Qt Creator's code model
    # Additional import path used to resolve QML modules just for Qt Quick Designer
    # Default rules for deployment.
    qnx: target.path = /tmp/$${TARGET}/bin
    else: unix:!android: target.path = /opt/$${TARGET}/bin
    !isEmpty(target.path): INSTALLS += target


    qputenv("QT_IM_MODULE", QByteArray("qtvirtualkeyboard"));

    Imports are done automatically:

    1. import QtQuick 2.9
    2. import QtQuick.Window 2.2
    3. import QtQuick.VirutalKeyboard 2.2
    5. Window {
    6.   id: window
    7. ...

    An inputPanel is added on a window

    Finally, without touching anything, I tried to compile and execute the code.
    Compilation done without any troubles, then executing i got the following error:

    QML debugging is enabled. Only use this in a safe environment.
    libEGL warning: DRI2: failed to authenticate
    qt5ct: using qt5ct plugin
    QQmlApplicationEngine failed to load component
    qrc:/main.qml:3 plugin cannot be loaded for module "QtQuick.VirtualKeyboard": Failed to extract plugin meta data from '/usr/lib/arm-linux-gnueabihf/qt5/qml/QtQuick/VirtualKeyboard/'
    09:49:28: /home/pi/workspace/build-test3-manuDesk-Debug/test3 exited with code 255

    /usr/lib/arm-linux-gnueabihf/qt5/qml/QtQuick/VirtualKeyboard/ exists and the path is accessible.
    I tried to cross-compile QT entirely and replace with the one got by cross compiling and got the same error.
    I tried to change arbitrary versions of virtualkeyboard imports but I wasn't lucky enough.

    Quite sure it's something terribly stupid (and maybe not related to QT) but I don't where to find any solution...
    Thanks for any help.

Log in to reply