Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

No rule to make target with msvc



  • Hello,
    I try to make a program using QWebEngineView and I learnt i have to use a kit msvc because MinGW isn't compatible.

    So I've changed it to various msvc kits (all I could activate) but each time, I have the same error :
    -1: erreur : No rule to make target 'A:/Programmes/Qt/5.14.1/msvc2017/lib/libQt5Widgets.a', needed by 'ZNavigo.exe'. Stop.

    I looked for solutions on internet and I have found that I should have the compiler "Microsoft Visual C++ Compiler 15.0 (amd64)" or another version but I don't, I just have the clang compiler and I don't know if the error could come from here, and I don't find how to install it.

    Otherwise, I don't know where this error could come from.

    I tried to delete "widgets" in the .pro file but the error came back with "libQt5Gui.a" so I think it's a problem with all the libraries

    I was using Qt 5.13, so I installed Qt5.14.1 and try with kits from this version but it didn't change anything and I still have the same error.

    thanks by advance
    maxcatl


  • Moderators

    hi @maxcatl and welcome,

    you have to get the MSVC compiler from microsoft directly. (Due to distribution rights) the easiest way is to download Visual Studio Community version, during the install wizard, make sure to select the c++ options (and preferably the 2017 version and not the 2019)

    QtCreator should pick up the new compiler during next start, rebooting your pc after the installation will also be helpful!



  • @J-Hilk thanks for the reply.

    So I have downloaded the visual studio and installed msvc 2017 with it.
    But after restarting my pc, qt is still unable to find the compiler when I click the re-detect button.
    I've tried to look for in the directories made by visual studio and there are some interesting things in there but I don't really know where the compiler is and how it is named.

    max


Log in to reply