Qt Mobility Beta 2 and QCamera



  • Hi,

    I extracted the qt-mobility-symbian-opensource-1.1.0-beta-epoc32-3.1.zip on my SDK. (that's ok)
    I installed the qt-mobility-symbian-opensource-1.1.0-beta-s60.sis on my device. (that's ok)
    I compiled the example of QCamera, no errors. (that's ok)

    But when I run on device, the program return a error:
    Process 485, thread 486 stopped at 0x79848fd0: A data abort exception has occurred.

    Debugging: I found that problem occurs when try to allocate/create an QCamera object.

    Someone have the same problema?!
    Note that I dont use the source code, only the binaries.

    Thanks!

    UPDATE:
    I have programs using accelerometer (with QtMobility 1.0.2) and works fine!
    But, with QtMobility 1.1 beta 2, Them show the same error of QCamera.


  • Moderators

    Did you check the capabilities granted to the application? IIRC the camera needs the UserEnvironment capability to be available.



  • Yes, I am using the UserEnvironment capability.



  • i have this problem too. any time i use QCamera, that error will be appearing... anybody can help??



  • "check here for some refference....":https://projects.developer.nokia.com/qcamera/


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.