Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Programs can't start on Android with Qt 5.14.x.



  • Hello !

    Since update 5.14.0, I'm no longer able to start a program under android. The program freezes on a white screen with the errors :

    W ResourceType: Invalid package identifier when getting bag for resource number 0x00000000
    E Qt: Can't create main activity
    E Qt : android.content.res.Resources$NotFoundException: String array resource ID #0x0.

    When I try to create an .aab package, qt Creator can't sign the application.

    Everything worked fine with Qt 5.13.2 and earlier.

    I use Qt Creator 4.11 and the Android ndk 20b.

    what could happen?

    Thanx !



  • Hi, does your program contain qml?

    If so, you may try to disable "Qt Quick Compiler" from “Projects -> Build Settings -> qmake -> Enable Qt Quick Compiler” which worked for me.

    Another solution might be related with you androidmanifest.xml file. You may try to delete your existing androidmanifest.xml file (of course take a copy of it before deletion) and then use "Create Templates" button in Qt Creator to generate new one. You can find given button in the following window. After creating new template, you can move your settings from previous manifest file.

    64796616-d0df-4966-8514-40c4a76fe1e7-image.png

    Finally, you may want to check out items listed in QT for Android Known Issues

    I hope one of above solves your problem.



  • I tried your solution number 2 (create a new androidmanifest.xml file) and it works perfectly!

    Many thanks mfatih!



  • @Francky033 Happy to hear that.



  • @Francky033 Solution 2 worked for me too!


Log in to reply