Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

FFmpeg crashes when running excutable.



  • Hi,

    I wrote a movie player using OpenGL, OpenAL and FFmpeg.
    When I run using Qt-creaotor(by clicking green arrow button),
    it runs and plays movie always well.
    But when I click generated excutable, it runs first few times and later it crashes. So if I turn my computer off, I could run it again, but after few runs, it crashes. Even after crash, if I run it from Qt-Creator, it runs well. but back to
    excutable, it still crashes. It seems Qt-Creator run some kind of cleanup the r
    emnants from previous run. But I don't know exact reason and how to solve it.
    Does anybody have similar experience? Thanks.


  • Lifetime Qt Champion

    Hi,

    What OS are you running ?
    Usually on Windows, you first have to follow the deployment procedure in order to execute the code outside Qt Creator. The most simple is to use windeployqt.



  • @SGaist
    I am using windows 10. I build my app statically, so I don't have to use windeployqt. And I loaded openal, ffmpeg dynamically. I am not sure whether there is a ffmpeg function to clear up previous load.


  • Lifetime Qt Champion

    Did you modify any environment variable in Qt Creator ?
    How are you using ffmpeg and the other libraries ?


Log in to reply