statically compiling Qt 5.11.3:ERROR: Feature 'gstreamer_1_0' was enabled, but the pre-condition 'libs.gstreamer_1_0' failed.



  • I encountered the following problem when statically compiling Qt 5.11.3 using Raspberry Pi:

    ERROR: Feature 'gstreamer_1_0' was enabled, but the pre-condition 'libs.gstreamer_1_0' failed.
    

    This is my configuration:

    ./configure -v -prefix /usr/local/qt5-arm -static -release -opensource -confirm-license -xplatform linux-arm-gnueabi-g++ -no-opengl -no-compile-examples -gstreamer 1.0
    

    I found a similar issue, but it didn't solve my problem in the end:

    https://forum.qt.io/topic/85955/reinstall-qt5-with-qtmultimedia-using-ubuntu-mate/13


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You should check the configuration test logs to see what went wrong.

    Might be a silly question but did you install the GStreamer development packages ?



  • @SGaist Hi,happy new year.

    yes,I have installed gstreamer1.0-dev on the raspberry pi...

    pi@raspberrypi:~/jie $ sudo apt-get install gstreamer1.0-dev
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Note, selecting 'libgstreamer1.0-dev' for regex 'gstreamer1.0-dev'
    libgstreamer1.0-dev is already the newest version (1.14.4-1).
    The following package was automatically installed and is no longer required:
      point-rpi
    Use 'sudo apt autoremove' to remove it.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    

    but this configuration is incorrect and I get the following error:

    ERROR: Feature 'gstreamer_1_0' was enabled, but the pre-condition 'libs.gstreamer_1_0' failed.
    

    Other configurations are correct....and I removed the -gstreamer 1.0 option and the configuration was successful.

    thanks...


  • Lifetime Qt Champion

    There are other GStreamer-1.0 related development packages that you are likely missing. You should check the test logs to see exactly what failed.



  • @SGaist Ok thank you very much for your reply, I think I will do it another way...


Log in to reply