Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Run Qml application on raspberry pi



  • Dear Qt Experts,
    I already compiled the qt-everywhere-opensource-src-5.9.8 on raspberry pi3 successfully. But when I run the qml application in raspberry,I am getting error message like,

    pi@raspberrypi:~/testqml $ ./testqml -platform linuxfb:fb=/dev/fb0
    JIT is disabled for QML. Property bindings and animations will be very slow. Visit https://wiki.qt.io/V4 to learn about possible solutions for your platform.
    This plugin does not support createPlatformOpenGLContext!
    Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlagsQSurfaceFormat::FormatOption(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DoubleBuffer), swapInterval 1, profile QSurfaceFormat::OpenGLContextProfile(NoProfile))
    Aborted

    Any help would be highly appreciated,
    Thanks.


Log in to reply