Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

5.9.8 no longer installs/runs on macOS Sierra 10.12.6



  • Well this is annoying. We have some reference systems to build for older operating systems including one for MacOS Sierra (10.12.6). I was developing code with 5.9.8 then an update came down the pipeline and I could no longer launch QT Creator. I wiped my Applications/Qt folder and have been trying to reinstall 5.9.8, but no luck.

    I've tried older versions through qt-unified-mac-x64-3.1.1-online.dmg but no luck.

    Qt Creator.app version is 4.11.0, when I launch it informs me that I need macOS 10.13 or later. This was not true in November, at least based on the Makefiles:

    #############################################################################

    Makefile for building: libdxflib.a

    Generated by qmake (3.1) (Qt 5.9.8)

    Project: ../dxflib-3.17.0-src/dxflib.pro

    Template: lib

    Command: /Applications/Qt/5.9.8/clang_64/bin/qmake -o Makefile ../dxflib-3.17.0-src/dxflib.pro -spec macx-clang CONFIG+=debug CONFIG+=x86_64 CONFIG+=qml_debug

    #############################################################################

    However, I can launch Assistant, Designer, Linguist and other apps in 5.9.8/clang_64/bin along with MaintenanceTool.app

    Any suggestions?


  • Lifetime Qt Champion

    @jet-townsend so this is mainly about Creator itself?

    You can download an older version from download.qt.io and try that. Online installer only provides the latest version, which is not always compatible to older OS releases.

    Regards



  • That fixed it. I thought the online downloader would installed the correct set of applications for a given version.


  • Lifetime Qt Champion

    Hi @jet-townsend,

    No, the online installer has no knowledge of your system, it installs what you select.

    Unfortunately, only the latest Creator version can be installed, and that is not always compatible to your system. E.g. Creator 5.11.0 is precompiled against Qt 5.14.0.

    Regards


Log in to reply