Problems with Qt on belle and after installation of ovi maps from beta labs



  • Hi,

    i recently get lots of complaints about my CacheMe application. It turns out that the people complaining are either Nokia employees having access to symbian belle or people who have installed ovi maps from the beta labs.

    The symptoms are:

    • The QGroupbox witdget has white text on nearly white background
    • A QComboxbox popup is only a few pixels wide when phone is in landscape mode
    • And worst: The applications just frequently crashes/closes

    The questions:

    • Are these known problems? (e.g. the QGroupbox and qcombobox issues can also be seen in qtcaching and other qt applications)
    • What exactly gets replaced when i install the beta labs version of ovi maps? Is the qt core being replaced?
    • How do i remove the ovi maps from beta labs completely and get qt back to its previous state?

    Regards,
    Till



  • The QComboBox issue was fixed recently. See https://bugreports.qt.nokia.com/browse/QTBUG-20932 for details. Not sure whether it is included in the Qt that is included in Nokia Symbian.

    Haven't heard about QGroupBox issue. Any chance providing a screenshot? Does your app use webkit?



  • Ah, found the QGroupBox issue as well.
    It is this one: https://bugreports.qt.nokia.com/browse/QTBUG-19782

    It is fixed AND is certainly included in the Qt release for Nokia Symbian devices.



  • I installed the Ovi maps Suite from beta labs yesterday and just found out what problems it causes.
    As Till already mentioned the readibility of the coordinate and distance data in CacheMe is close to nothing, This makes the app almost unusable.
    The effects on my own app (QtCaching) aren't that serious for usability.

    I also would be really interested in answers to Till's questions from above.

    Regards
    Frieder



  • a) Problems seem to be known (not sure of the crash issue, though, but it is also very likely fixed in the latest Belle SW). The Qt version in Belle is not yet final. I asked the Nokia RnD team to include the QComboBox fix into Belle. Lets hope it gets there.

    b) I presume that BetaLabs ovi maps pulls in some RnD version of Qt (also it might bundle in new QWebKit and/or Mobility), which then replaces the previous version of libraries (due to having a "higher" version number).
    This would need to be asked from ovi maps team - probably from Beta Labs forums.

    c) Re-install Qt 4.7.3. If this cannot be done (bundled in Qt might claim to have higher version number and thus "downgrade" might not succeed), then I guess restoring factory settings with *#7370# needs to be done.



  • Thanks for the detailed feedback. The graphic glitches are annoying, but i am sure most people will live with them. And since i am seeing this in other applications as well, i am sure this will be fixed.

    But the crashes are really a problem. I am trying to track them down and currently it seems to be related to placing objects on a qgraphicsgeomap while the window containing the map isn't the active one. If that's really the problem then i can probaby work around that.

    The beta labs are one source, but i've been told that installing "gps info qt" from ovi store also pulls in those qt 4.7.4 i am having problems with.

    It's really tricky to cope with such updates ...



  • a) I can confirm that the QComboBox and QGroupBox issues are going to be solved in either Belle update (for devices that have already Belle) or in the Belle upgrade for existing devices (N8, E7, ...)

    b) What is your crashing app? QtCaching? I can tip the RnD team to double-check that if using latest Belle, will it still crash.

    S.



  • It's CacheMe (available for Symbian^3 in the Ovi store).

    I am compiling the same application for Maemo, Desktop Linux, MeeGo, Mer and previous Symbian-Qt versions, so i wouldn't expect this to be an issue of CacheMe itself ... but of course i can't be sure and will investigate this further.

    Thanks for your help.



  • Thanks (I was not implying it was your app fault). The problem seems to be that somebody green flagged Qt library updating to smart installer, when it was not yet ready.

    But thanks for the heads up, now I need to put out some fires. :)



  • Not adding objects to a map widget while its parent window is inactive really seems to solve the problem. I changed cacheme to delay the update until 200ms after the window containing the map becomes active again and i don't see the crashes anymore.

    I'll upload the version with the workaround soon, so no reason to file a bug for this. This should be a rare case, anyway.

    The updates of the map objects are caused by the phone being rotated and the map thus being redrawn. There's no way on the desktop to change the layout of a window not being the active one, so i might just not see the issue there ...



  • Not sure if this is the right place to ask. But that strange qt version installed this way makes my app output the following lines:

    [Qt Message] ********************************************************************************
    [Qt Message] Qt Location requires usage of app_id and token parameters obtained from:
    [Qt Message] https://api.forum.nokia.com/ovi-api/ui/registration
    [Qt Message] For more information about app_id and token please consult:
    [Qt Message] http://doc.qt.nokia.com/qtmobility-latest/location-overview.html#the-nokia-plugin
    [Qt Message] ********************************************************************************

    I have requested and got an app id. But i don't find any explanation where to set it in my qt program. I suspect it's something i need to give to the QGeoServiceProvider ... but where and how?



  • There was a bug related to this that was closed quite recently:
    https://bugreports.qt.nokia.com//browse/QTMOBILITY-1922

    Although I don't know how long it will take to flow through to SmartInstaller / SDK updates.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.