Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[END] QCA Crash on Symbian Device



    • Latest news -
      The problem is due to missing QCC-OSSL Plugin in Symbian Device. No solution at this moment.

    I am using QCA and i have build the Library for Symbian 4.6.3 Debug and release mode

    When i implement the code in Symbian Qt Project and Launch in Nokia C7. The app will crash when it run "Cipher"

    Run below 3 lines still no problem
    @QCA::Initializer init = QCA::Initializer();
    QCA::SymmetricKey key = QCA::SymmetricKey(QCA::hexToArray("57083063169A37AECB53223A66D0E6F7EB2"));
    QCA::InitializationVector iv = QCA::InitializationVector(QCA::hexToArray("A795271106E520B7108E8DE82D1A541A"));
    @
    Will Crash once run below line
    @QCA::Cipher cipher = QCA::Cipher(QString("aes256"), QCA::Cipher::CBC,QCA::Cipher::DefaultPadding, QCA::Encode,key, iv);@



  • So you did install the plugin providing AES too?



  • I have compiled the qca-ossl-2.0.0 plugin. However, it seem build for desktop only. And my App can run in Desktop and Simulator platform perfectly.

    "The steps i tried":http://www.essentialunix.org/index.php?option=com_content&view=article&id=48:qcatutorial&catid=34:qttutorials&Itemid=53

    I'm trying to build it for Symbian after read your post. But it either display Undefined interface error or "QtCrypto: No such file or directory" error.

    Thanks Volker



  • I never used QCA for symbian targets, so I'm not sure what to do. I suspect the very same steps for a desktop target, though. That includes compiling for the symbian target using the correct toolchain, installig everything into the Qt tree for symbian and adding the needed plugins using the same steps afterwards.

    Sorry for being that less helpful, I can't test it myself.



  • Thanks Volker ~ Do you know anyone can help on this issue?



  • [quote author="MagicR" date="1320286590"]Thanks Volker ~ Do you know anyone can help on this issue?[/quote]

    Nobody personal, maybe someone else on DevNet can jump in here.



  • Thanks Volker~


Log in to reply