Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Error when compiling mysql driver for Qt(Debian Linux)



  • I tried to compile the qmysql driver, but I get errors when compiling, specifically the error: /home/cesar/Qt/5.13.2/gcc_64/mkspecs/features/qt_plugin.prf:59: error: Cannot write file / mkspecs / modules- inst / qt_plugin_qsqlmysql.pri: Cannot create parent directory.
    I don't know what the problem might be, I already placed the include corresponding to mariadb (/ usr / include / mariadb) and the libmariadbclient.so library in the mysql.pro file.
    As I read in StackOverflow, they seem to be permission issues, but it is assumed that being installed Qt in / home / Qt should not generate problems with write permissions, what do you think the problem might be?



  • @CesarB794 Have you tried installing qmysql plugin,

    sudo apt-get install libqt5sql5-mysql
    

    and how did you installed QT?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Can you show the modifications you made ?
    What sources are you using ?
    How did you get them ?


Log in to reply