Planned maintenance has been done but it did not solve the problem. So work will continue on this and a new time for trying updates will be announced asap.

License question...



  • Hi, I would like to know if develop android apps is considered embedded or if I can develop it using LGPL license.
    Many thanks.

    Stefano


  • Qt Champions 2018

    @Stefanoxjx said in License question...:

    is considered embedded

    No

    You can use LGPL as long as you don't violate it.


  • Moderators

    @Stefanoxjx
    As always, I'm not a lawyer! So everything I say may be wrong.

    AFAIK publishing apps to the App Store or PlayStore falls into the LGPL area.

    However, if you sell devices that run android and you preinstall your qt made app on it, than that may need an embedded license, or at the very least consulting with the QtCompany & a lawyer



  • Thanks for answers.
    I should need to develop a small app for a customer and he will install it in his android devices, but without pass through Google Play.
    Then, if I understand correctly, in this case I can't use LGPL license.
    Is correct?
    Thanks.


  • Moderators

    @Stefanoxjx
    this falls in-between those too,
    If the customer installs the apk himself, than I would assume LGPL as well



  • Many thanks for your help :)



  • As other's have said given your situation you should be fine. The primary obligation you must adhere to when using LGPL libraries is enabling the user to use their own version of the LGPL licensed software, in this case the QT libraries.

    Situations where you will run into issues with the LGPL license:
    A. You compile any qt library code into your binary. In this case you'd be obligated to provide the source code and tools to rebuild it with a different Qt version to anyone who requested it.
    B. You put your program on an embedded system and then lock the user out of accessing the internal software. In this case even if the libraries were linked dynamically the user still couldn’t use their own version of Qt since they can not access the library files to replace them. This is actually a loophole that was fixed in LGPL 3. Technically earlier versions of Qt used LGPL 2 and you might be able to get around this but it's legally grey and I wouldn’t advise it.
    C. You change any of the Qt library source code. When you directly edit LGPL software source the rules change a bit. More than likely you'd need to get the commercial license.

    If all you're doing is making an android app then you should be fine to use LGPL. I'm not an Android developer but I believe Qt apps link to dynamic libraries by default, in which case the user had full access and you aren't responsible for how they are managed.

    ** Standard "I'm not a layer" disclaimer. I'm just sharing the findings of my own research on LGPL, this is not legal advice and I could be wrong about any of it.



  • Hi khislop, and thanks for your answer.
    In all answer's I saw that "should" and "could" is a costant.
    For better clarification, I try send question to Qt team.
    I hope to receive an answer, otherwise for security, for app development I will divert to another development environment.
    Many thanks for your help :)


  • Qt Champions 2018

    @Stefanoxjx said in License question...:

    In all answer's I saw that "should" and "could" is a costant.

    This is because people here are not lawyers.
    If you want to have somewhat safe answer you should ask a lawyer.



  • Yes, I understand and I thank those who sent me answers anyway.
    I hoped to receive an answer from someone that already developing apps and had experience in this regard.


  • Qt Champions 2018

    @Stefanoxjx In the company I'm working for we use Qt up to v5.6 for commercial products. We do not use newer versions as those are now LGPLv3 instead of LGPLv2. LGPLv3 requires you to provide the users of your software the possibility to replace (relink) Qt with their own Qt build. This normally requires you to provide object files (*.o) to your users if they ask you to do so. But you do not have to provide source code. So, if you can fulfil LGPLv3 you can use open source Qt version.


Log in to reply