Building Qt for WinCE on Toradex Colibri



  • Hello,

    I'm working on the product Toradex Colibri T20, and I'm trying to build Qt to program on this platform, but it does'nt work...
    I found this wiki to help me:
    http://wiki.toradex.com/index.php/Nokia_QT_on_the_Colibri
    and I followed the instructions step by step, but an error always occured during the nmake (or sometimes during de configure). Lately, I was told that ceconfig.h file wasn't found, so I installed windows ce 5.0 SDK, and now it's windows.h which is missing.
    I've been on this for a few days now...
    Does anyone know what is the reason for those errors?

    Thank you for your time!



  • after configuration finished, open projects.pro from Qt sources directory using your visual studio and try to compile using VS.
    you'll need to have Qt VS-Addin installed.



  • Thank you for answering, but just trying to open projects.pro made VS crash...
    Maybe I'm not patient enough, but it has done that 4 times...
    I did "open Qt project files" in the add-in, then selected the right projects.pro, then VS tells me that projects.pro has already been generated, but if I ask to launch the old generated project, nothing happens, and if I ask to regenerate the project, it loads, loads, and crashs...



  • First up, take care with the instructions they give as it instructs you to compile Qt as a static library. Using this you might run into problems with licensing if you're going to use Qt with the LGPL license.

    Configuring Qt for WinCE can be a bit frustrating, so here are some things to try.

    1. I've found using a shadow build is better than trying to compile directly in the folder you've extracted Qt into. To do this see "here":http://doc.qt.nokia.com/4.6/shadow-builds-wince.html
    2. If you tried compiling before installing the SDK this will certainly fail. My tip would be delete the Qt source folder you have and extract it again an re-try now you have the SDK installed
    3. I've just noticed in those instructions they give the paths to msvc2008, but configure for msvc2005.

    Hope this is of some help.

    Steve



  • And one other thing. It's not you being impatient, I've found opening the entire Qt project in VS will crash it. From what I've found it's something in the QScript project that causes it although I've never bothered to take it any further.



  • Thank you for those informations, I'll see what I can do and keep you informed.



  • So!
    I've finally successfully build Qt for wince (don't really know how, though...).
    Then, after some trouble to link it with VS (I had to downgrade the add-in to 1.1.7), I finally build an application for the colibri... except it did'nt worked.
    I've got this message:
    "Project : error PRJ0002 : Error result -1 returned from ''."
    for any application I can write with Qt.
    Any thought?
    I'm starting to think than something greater than me don't want me to be able to work...

    Thanks for your time



  • You should compile .pro by VSCompiler. I've done many projects with Qt for WinCE and there was no problems. But i never suggest you using static build due to memory limits on ARM devices.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.