QtCreator not showing widgets in design view for HarmattanProjects



  • Hi i am a newbi and just installed qt, I have tried both online and offline versions. I have updated all components. I am running OSX 10.7.2.

    My problem is that if I create a new QTQuick Application with QTQuick Components for Meego/Harmattan and open up MainPage.qml I dont see anything in the preview area and I dont have for ex. Button in the QtLibrary area to create a new button.

    If I try creating a Symbian instead it works fine.

    Is it supposed to be like this or am I missing anything.



  • I've just installed the latest Qt SDK with the offline installer on Windows XP.
    It seems I have the same issue here.

    The Harmattan QtQuick components don't show up in the Design view of
    Qt Creator and the drawing canvas is blank. However, I can edit the app
    in the Edit view and when when I fire up the simulator, the app runs fine.
    I've tried this with the default app generated when creating a QtQuick
    project for Harmattan.

    Any help would be appreciated by this newbie :)



  • Same experience here. Most disheartening for someone trying to get into Qt development.

    I also went through the example Battery Status tutorial which doesn't work even on Symbian because of a change in QTMobiity yet the tutorial refers to the older API.



  • After a bit of Googling, apparently the Harmattan components aren't shown in Qt Designer because there is no integration with them and Designer.

    http://lists.qt-project.org/pipermail/qt-creator/2011-November/000041.html

    I hope this is fixed at some point soon as it's not clear why they don't show for Harmattan but do for Symbian and I wasn't intending to write Symbian code when I started the project.



  • Some improvement after the latest update: it is now possible to see and use the Harmattan components in Qt Creator. However, they are not properly drawn on the canvas, only the outline is visible.

    This update makes it somewhat easier to design but still hoping for full support.



  • Is it still supposed to be like this?

    I have this version:

    Qt Creator 2.4.1
    Based on Qt 4.7.4 (32 bit)

    Built on Jan 25 2012 at 11:24:30

    From revision 8cd370e163

    Copyright 2008-2011 Nokia Corporation. All rights reserved.

    running on Ubuntu 10.04 LTS.

    I tried to follow one of the tutorials that was obviously written for Symbian and I assumed that equivalent features would be available for Harmattan/N9. But there is almost nothing in the Library, not even buttons or labels.

    So, have I missed something (quite likely as this is my first attempt at app programming of any kind) or do I have a faulty installation?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.