Native compile error on Raspberry Pi3 for Qt6



  • Everything compiles fine up until Linguist. I get the following error.

    gmake[4]: Leaving directory '/opt/qt5/qttools/src/linguist/lrelease-pro'
    cd lupdate/ && ( test -e Makefile || /opt/qt5/qtbase/bin/qmake -o Makefile /opt/qt5/qttools/src/linguist/lupdate/lupdate.pro ) && gmake -f Makefile
    Project ERROR: Unknown module(s) in QT: tools-private
    gmake[3]: *** [Makefile:153: sub-lupdate-make_first] Error 3
    gmake[3]: Leaving directory '/opt/qt5/qttools/src/linguist'
    gmake[2]: *** [Makefile:158: sub-linguist-make_first] Error 2
    gmake[2]: Leaving directory '/opt/qt5/qttools/src'
    gmake[1]: *** [Makefile:49: sub-src-make_first] Error 2
    gmake[1]: Leaving directory '/opt/qt5/qttools'
    gmake: *** [Makefile:1006: module-qttools-make_first] Error 2


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You title talks about Qt 6 yet your path shows Qt 5, which one is it ?



  • I pulled it from github. Thought it was going to be Qt5 but as it compiles it showing 6.0.0. So I believe it's 6.0.0


  • Lifetime Qt Champion

    So you are on the dev branch which is indeed Qt 6.

    If you want Qt 5, then switch to one of the tags or 5.XX branches.



  • Don't really care as long as it compiles on the Raspberry Pi3 and allows for other programs to build against the cmakes that are looked for.


  • Qt Champions 2018

    @ShadowKni You should care as Qt6 is in development and can potentially cause more issues when building than Qt5.


Log in to reply