Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QT and STM32F769i - DISCO (PROBLEM)



  • Hello everyone, I have the following problem, I set everything as it was shown on the webinar (Qt) regarding the STM32F769 circuits and I wanted to open the Automotive example from the Qul_0.1.0 folder when opening and building it extract the following errors "Syntax error", "importing the package requires giving the version", " Expected token `{'" and I don't know how to fix it please help urgently
    best regards
    error.png



  • Please help me ? anyone ?



  • I have no idea, except: do you use a Qt version & other build tools the example requires? Being new tech it probably requires almost-latest versions of tools.



  • @AlexR
    I think you are speaking about this webinar:
    https://www.youtube.com/watch?v=uUoIXip9jSw
    May be it's better to fastforward webinar again and it could help to find out what's happening.

    As far as I know this tech is not widely used an guys from ST made some efforts for QT to work on this platform.
    You definetly should ask this question on ST Microelectronics forum:
    https://community.st.com
    I see that there are only questions about Qt& SMT32MP1, but it completly different platform based on Yocto Linux.



  • @bagumka said in QT and STM32F769i - DISCO (PROBLEM):

    SMT32MP1

    Hello, I've done the same thing 3 times on the webinar and I still have the same error, I've tried all python versions from 2.7.0 to 2.7.8 and nothing further is the same error, I don't know what I can do, I'm also curious when the producer Qt will introduce STM32F769 support as a standard greetings


Log in to reply