Important: Please read the Qt Code of Conduct -

Compatibility of older VS 17 versions

  • Dear Forum,

    i searched for a while not getting sufficient answers.
    I have Visual Studio 2017 V15.5.3 and QT 5.12.4 on windows 10. Where can I find the compatible QT VS Tools for my configuration? The one from the VS Store (2.4.1) does not work. I also tried 2.4.0 from the "old versions" of the download section. It does also not work. Try and fail seems like it could be a source of future errors in VS so I would like to know the correct QT Tools Version in advance.

    Cheers and thanks in advance!


  • Lifetime Qt Champion

    Hi @dnns,

    Is the one from the store the same as under ?

    The one from the VS Store (2.4.1) does not work.

    Can you elaborate a bit more what does not work?


  • Hi @aha_1980 ,
    yes the store provides V2.4.1.
    The error happened to other people before: "The 'ProviderPackage' package did not load correctly." This leads to a slower startup of VS and the QT VS Tool button to be stuck on "initializing".

    Check: (even though QT might not have been the root of the issue in this particular thread)

    I actually proceeded to install older versions, f-ing up my VS. I re-installed it, tried 2.4.1 again and the Error above happened again.

    I again installed older versions using the command line interface of the VSIXInstaller. V2.3.0 happened to work. As this costed me a couple of hours I stopped there, not further investigating on the error. I can however provide the install-log of V2.4.1 if anyone of the QT-Team is interested.

    As it works now, I consider this case closed. I will stay on V2.3.0 for the sake of my mental health. If this really is a compatibility issue, a compatible Version table should be uploaded somewhere.

    Cheers and thank you nevertheless @aha_1980 ,


Log in to reply