Please nominate your Qt Champions for 2021!

Error during uninstallation process

  • QT 5.12.2 was installed some time ago on KDE Neon 5.16 via the online install into /usr/bin.
    Now I run the maintenance tool and added Qt 5.13.1

    Downloading the files was without error.
    However, during install I received these errors:

    Error during uninstallation process: Cannot copy file "/usr/bin/Qt/Tools/Qt3DStudio/bin/imageformats/" to "/usr/bin/Qt/Tools/Qt3DStudio/plugins/imageformats/": Cannot open /usr/bin/Qt/Tools/Qt3DStudio/bin/imageformats/ for input

    Error during uninstallation process:
    Cannot copy file "/usr/bin/Qt/Tools/Qt3DStudio/bin/platforms/" to "/usr/bin/Qt/Tools/Qt3DStudio/plugins/platforms/": Cannot open /usr/bin/Qt/Tools/Qt3DStudio/bin/platforms/ for input

    Error during installation process (qt.qt5.5131.src):
    Error while extracting archive "installer://qt.qt5.5131.src/5.13.1-0-201909031251qtdeclarative-everywhere-src-": Cannot open file "/usr/bin/Qt/5.13.1/Src/qtdeclarative/tests/auto/qml/ecmascripttests/test262/test/language/expressions/tagged-template/cache-differing-raw-strings.js" for writing: Permission denied

    To the first error: there is no such directory "imageformats". There is only one file Qt3Dviewer in the dir.

    To the second error: there is no"platforms" directory there.

    To the third error: "Permission denied" makes no sense. The /usr/bin/Qt/5.13.1/... path was just created by the installation. After the install, there are four files in this dir:

    • cache-different-functions-same-site.js
    • cache-differing-expressions-eval.js
    • cache-differing-expressions-new-function.js
    • cache-differing-expressions.js

    When these error messages came up, I clicked 'ignore' thus the process could 'complete'.

    I don't know how serious these errors are.
    However, trying to run a "Example" project generates a "GL/gl.h file not found" error. This is regardless if i set the kit to 5.13.1 or 5.12.2.

    Anybody? How to go from here?

  • Solved.
    I uninstalled all previous installs.
    Downloaded the offline install.
    It MUST be run from the terminal as root/sudo. Else it fails.
    Missing GL/gl.h: opengl is not installed.

    Being on KDE (Ubuntu)
    sudo sudo apt-get install mesa-common-dev
    sudo sudo apt-get install libglu1-mesa-dev -y

  • Lifetime Qt Champion


    You should not install Qt in /usr/bin. The default is either the home folder or the /opt folder. Unless you're on a shared computer where several people are going to use Qt, you should install it in your home folder.

Log in to reply