uic problem



  • Trying to build my own program:

    20:15:20: Running steps for project vspheroid...
    20:15:20: Starting: "/home/gib/Qt5.13.0/5.13.0/gcc_64/bin/qmake" /home/gib/vspheroid-fem/GUI-VTK/vspheroid.pro -r -spec linux-g++
    /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version Qt_5.13' not found (required by /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic) /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: versionQt_5' not found (required by /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic)
    /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version Qt_5.13' not found (required by /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic) /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: versionQt_5' not found (required by /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic)
    /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version Qt_5.13' not found (required by /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic) /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: versionQt_5' not found (required by /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic)
    /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version Qt_5.13' not found (required by /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic) /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: versionQt_5' not found (required by /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic)
    20:15:21: The process "/home/gib/Qt5.13.0/5.13.0/gcc_64/bin/qmake" exited normally.
    20:15:21: Starting: "/usr/bin/make"
    Makefile:2746: warning: overriding recipe for target 'moc_qmycheckbox.cpp'
    Makefile:1644: warning: ignoring old recipe for target 'moc_qmycheckbox.cpp'
    /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic ../GUI-VTK/vspheroid.ui -o ui_vspheroid.h
    /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version Qt_5.13' not found (required by /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic) /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: versionQt_5' not found (required by /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic)
    Makefile:3511: recipe for target 'ui_vspheroid.h' failed
    make: *** [ui_vspheroid.h] Error 1
    20:15:21: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project vspheroid (kit: Qt-5.13.0)
    When executing step "Make"

    I had earlier installed Qt 5.5.1 with this qmake location:
    /usr/lib/x86_64-linux-gnu/qt5/bin/qmake

    For some reason uic is looking here when trying to make ui_vspheroid.h, instead of using the Qt 5.13.0 libraries.


  • Qt Champions 2018

    @gibbogle said in uic problem:

    /home/gib/Qt5.13.0/5.13.0/gcc_64/bin/uic: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version

    It actually calls the correct uic, but wrong Qt libs are used.
    Did you try to delete the build folder, run qmake and build again?



  • @jsulm Yes, uic is looking at the libraries from the Qt 5.5.1 installation.
    Deleting the build directory, qmake and build gives the same result.

    I'd like to tell Qt Creator to forget all about Qt 5.5.1, but it doesn't seem possible. Qt 5.5.1 shows up as Auto-detected in the Qt Versions list (with a warning yellow triangle), while Qt 5.13.0 is Manual. The other difference is that Qt 5.5.1 is shown as "in PATH" while Qt 5.13.0 is not.
    In case you are wondering, I deleted not only the build directory but also the .pro.user file, so it is really a fresh project.

    On further investigation I see that the problem is created by having two versions of Qt Creator installed. The first (3.5.1) was created with Qt 5.5.1, and the other is the Qt 5.13.0 version. When I start Qt Creator by right-clicking on a .pro file and selecting Open with Qt Creator, something a bit odd happens. Initially two green Qt squares appear in the left-hand bar (I don't know what it's called). One (which displays "Qt Creator" when I move the mouse over it) has the green background of the logo flashing on and off for a few seconds, then disappears. The other "(Community)" stays - this is the 5.5.1 version. The one that fails must be the 5.13.0 version.

    I am not able to open the Qt Creator version that came with Qt 5.13.0. I tried changing the file association for .pro, but the only option is Qt Creator, with no indication of where it is. If I right-click on the executable nothing at all happens. If I try to invoke it at the command line I get this:

    gib@gigabyte:~/Qt5.13.0/Tools/QtCreator/bin$ ./qtcreator
    qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
    This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
    Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.
    Aborted (core dumped)

    So I guess my question has become this: How do I use the Qt Creator version in the Qt 5.13.0 installation?

    Thanks for your attention to this, by the way. I really appreciate it.

    Update: Using the "Search your computer" list of applications, I see two Qt Creator versions, one "(Community)". Clicking on this brings up yet another version, 4.9.2. This one behaves normally with my program, showing the project tree and not giving configure errors. The build does not give those uic errors. If I was not such a beginner with Ubuntu I'd know how to make this the Qt Creator version that is started when I right-click on a .pro file.



  • In an attempt to fix the confusion with Qt Creator on my system, I reran qt-unified-linux-x64-3.1.1-online.run, setting up Qt 5.13.1. When it completed the installation it tried to start Qt Creator, but this crashed:

    Sorry, Ubuntu 16.04 has experienced an internal error
    ExecutablePath
    /home/gib/Qt/Tools/QtCreator/bin/qtcreator
    ProblemType
    crash
    Title
    qtcreator crashed with SIGABRT in QMessageLogger::fatal()
    ...



  • I have also tried reinstalling Qt with qt-opensource-linux-x64-5.13.0.run. Although the installation goes to completion, Qt Creator cannot be opened. I now find that I see only one Qt icon in the "Search your computer" list of Applications. Clicking that icon causes two Qt Creators to be invoked, but one fails to start and the other is version 3.5.1, from Qt 5.5.1. So I'm now in a worse position than before. How can I install Qt Creator 4.9.x?


  • Qt Champions 2018

    @gibbogle Try to remove Qt stuff from PATH - it should not be there.
    My guess is that QtCreator based on Qt 5.13 does not start for the same reason: system tries to load Qt 5.5 libs.
    This actually should not happen as you can have many different Qt versions on same machine (I do this here on my Ubuntu 18.04 without any issues). And QtCreator can handle many different Qt versions (configured in different Kits).



  • @jsulm I just upgraded to 18.04 (a rather nightmarish experience, and still the DNS is not set automatically), and then I followed your advice to remove Qt directories from the PATH. That fixed the uic problem. I have two versions of Qt Creator, one that I installed (Qt 5.13.0) the other I think automatically installed by Ubuntu (Qt 5.9.5). I have to use the 5.13.0 version, because if I use 5.9.5, uic only works with Qt 5.9.5, which lacks some recent features I need.

    So many thanks for all your help.
    Gib


 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.